DVD/Blu-Ray Drives hanging Computer!! Please help!

RhysAndrews

In Runtime
Messages
321
Hey guys!
I recently got a new computer, and so my old one has retired into its final years as a HTPC. It has these specs:

AM2 Athlon64 6400+ CPU (3.2ghz)
2GB Corsair DDR2 800MHz RAM
8600GTS
Gigabyte GA-M68SM-S2 Motherboard
Generic 500w PSU
Leadtek TV Tuner

The DVD-Writer in there had worked fine previously, and I took it out to install windows on my new computer, then returned it to the HTPC to reformat it / install Windows 7 64-bit RC.

Windows 7 took about 12 hours to install. Yes, I'm serious. But once it installed, all seemingly worked well. Media Center (eventually) picked up the TV Tuner card, I have HDMI output to my LCD TV, etc. HOWEVER, when I inserted a CD, Media Center played 5 seconds of the first track and then hung. I couldn't even close it, I had to reboot.

I then tried other disks, outside of media center. Same problem. If I tried to do ANYTHING to the drive from My Computer or Device Manager, explorer would usually crash. The disk rarely gets detected in My Computer, or in some cases, it works for a couple of seconds of playback / reading, before it dies again.

I gave up for a while... but yesterday I finally got an LG Blu-Ray / HD DVD Drive for it, so my DVD Drive could live in my new computer. The issue is still happening. The blu-ray drive was detected by Windows 7 fine, and by the BIOS. Same problems are occuring. I've tried putting the SATA cable in a different port, tried swapping the SATA power cables with the hard-disk, turned off all these SATA-related options in the BIOS, took out half my RAM, etc, but to no avail.

I'm dying to get this blu-ray drive working! Please help me out!
Thankyou,
Rhys
 

_-..zKiLLA..-_

Fully Optimized
Messages
3,952
What i would do is see if maybe you can run memtest and make sure your BIOS is updated then maybe check all your drivers and make sure everything is up to date. hmmm thats all i could really think of that might cause a hang up. no bluscreens right?

and im not sure about ur motherboard but my mobo has SATA drivers but if you have those make sure they're installed ;)

and one question, does the computer hang up with no drive installed? my mistake if its up there ^^ or its only when you try to access the disk correct? sorry, tryin to get the story straight
 

RhysAndrews

In Runtime
Messages
321
Drivers are up to date - havent installed SATA drivers but I didn't think it was required for newer OS'. + Windows 7 has all that bundled? I'll see.

Correct, it only hangs when I try to access the disk or drive.
 

_-..zKiLLA..-_

Fully Optimized
Messages
3,952
yeah thats true but it doesn't always have the updated version. its always good to check ;)

What are all the BIOS settings set to? like You should only need hard drive set to first boot drive (no cd) leave everything else disabled then. and make sure all that s.m.a.r.t. drive crap is turned off then it recognizes it as a secondary and the hd as primary right?
 

RhysAndrews

In Runtime
Messages
321
I tried turning SMART off, DMA transfer access, and disabled the CD Rom as a boot device. The SATA controller is in IDE mode, as opposed to RAID or AHCI. Both my hard-disk and my blu-ray drive are picked up as slaves.
 

RhysAndrews

In Runtime
Messages
321
Just the one hard-disk, and the blu-ray drive. All sata.
They're picked up as slave, on two different channels.
 

_-..zKiLLA..-_

Fully Optimized
Messages
3,952
Hmm well if you can boot i guess that works. Is it still giving you a problem? do you have any 3rd party software you can use? another thing i just thought of is you may need a blu ray codek because windows 7 doesn't support blu ray yet, i think..
 

RhysAndrews

In Runtime
Messages
321
@zKiLLA
the issue isn't at a software level. It's either at operating system / driver level, BIOS level, or hardware level. Because the issues occur even if I try to say disable and re-enable the DVD drive. It's not the software that crashes but usually explorer.exe or the device manager.

I'm not worried about blu-ray codecs just yet (I've got the right software though), I haven't even got a blu-ray disk.
 

_-..zKiLLA..-_

Fully Optimized
Messages
3,952
Well thats a freshly installed operating system so thats most likely not it. hmm (i really wish someone else would step in on this thread) you could contact LG support and see if maybe the drive is faulty. im not sure how often that happens but its possible.
 
Top