Direct 3D???

FuRgy

BSOD
Messages
1,692
Hi everybody!
I have a bit of a problem when I install a game called Hitman 2 silent assasin. (Yes yes, I know it's old but I haven't completed it yet....) It installs successfully, However when I click on the game the screen flashes and says-

Directd3D:Unable to create device. Try changing resolution or colour depth.

I have tryed right clicking on my desktop>>>Properties>>>Settings and changing True colour 32 bit to High Colour 16 bit, True colour 24 bit, 256 colours. But this has made no difference.the same message is displayed. I have also tryed going to the game config and changing the resolution to different ones but no luck there either...
Anybody know how to fix this problem?
Thanks to anyone who reads.
More thanks to anyone who replies!
 

CJ1

In Runtime
Messages
399
Have you tried patching the software and installing the latest graphics card drivers and direct x?
 

FuRgy

BSOD
Messages
1,692
:(

I have tryed downloading DFirect X 9.0. I have tryed diff colours; and diff resolutions...Gone to the website and have seen no patches..I have 3dfx voodoo3...does anybody have any other ideas???
:(
 

FuRgy

BSOD
Messages
1,692
Ok, I went to this link..http://hitmanforum.com/forum/faq_hitman.php#6
and followed these instructions....
If you are using a Voodoo card and you're getting this error, try the following...
In hitman2.ini...

1. Change "DrawDll RenderD3D.dll" to "DrawDll RenderOpenGL.dll"



now the game boots up...after the loading screen however my screen flashes and returns to windows..
I have tryed followiung these instructions...
# Make sure you have DirectX 9 or higher (IMPORTANT)
# try entering DXDIAG (Start/Run/type DXDIAG and enter). In the Sound Tab, turn down Sound Hardware Acceleration a notch or two, maybe even all the way down, there will still be sound, just not as good quality.
# in Hitman 2, disable EAX. alternatively, edit the hitman2.ini file and substitute "UseEAX 1" for "UseEAX 0"
# in Hitman 2, turn the number of voices down to 3/5.
# Get the right soundcard drivers (either the latest from your manufacturor, or windows defaults)
# install the AMD3D Dieselpower plugin for Hitman 2, and in the Hitman 2 sound settings, select it as your sound renderer.

but the same thing keeps happening...:(
Any ideas?
 
Top