Changing IP screws up router settings.

zero4zero

Daemon Poster
Messages
563
I have recently bought a Linksys wireless router and it is just a pain in the neck because of changing IP adress.
I have an application to which I have set up TCP / UDP ports to work with a given IP adress, but..... :mad: when the adress changes, the application doesn't work anymore, and to correct the situation I have to find my new IP adress, access my router and change the IP in my configuration for my application to work. Note: my other PC IP address is always the same :( .
Do you have a solution so I won't have to change my router settings every time my IP adress changes. (Linksys has suggested to use a static adress and DNS: gateway 192.168.1.1 and static address 192.168.1.20).
I thought of just setting my router to use only 2 address instead of the default 50, but I am not sure if it will work.
Any solutions?
Thanks
 

zero4zero

Daemon Poster
Messages
563
I found the solution myself! The problem was that initially when I checked where I had to go to open the TCP and UDP ports, Linksys has a gaming page where you put the application name and UDP/TCP used with an associated IP. But that didn't work to well cause using DHCP, the IP changed and I had to go back to my router settings so I had the right IP address.
Then I read about port forwarding and there was a good example. so I used port forwarding which had no IP association but open those ports to the network, but it didn't work any better. Until I read a simple phrase that said that a port can only be opened to one application. I removed the gaming application configuration and ZIPPO, everything works just fine now. The router is set and works perfectly...
So the catch was that I was open a port from 2 different router applications and that is what bugged it up.
 

DarkBlade1

BSOD
Messages
3,355
GJ!! Glad that you figured it out yourself, and this Thread probably would not have gotten much response.... YOu get more hits on this type of thing in the Networking thread area!!
 
Top