Can't backup Final Fantasy X

Not open for further replies.


Beta member

I have a M2 Modded PS2 and I've backed up over 50 games with no problem.

However, when I try to backup Final Fantasy X I get a read error at 50%. I've tried 2 drives & 4 different burning programs as well as DVD Decryptor . Nothing works. There are no major scratches on the disc.

Is there some sort of copy protection that I'm not aware of? Has anyone successfully backed up this game?

Any tips would be greatly appreciated.
Just finally got a good copy of Final Fantasy X here!

I was having trouble making a backup DVD for Final Fantasy X here. All of the programs I tried had no trouble reading the disk though. But the PS2 would not read the copies made by Alcohol 120% or by Nero. I used a Plextor burner for them. I then swithced over to my laptop because it has the latest Blindwrite Suite on it and a Pioneer burner. All of the backups from it have worked ..... I did the first on a RW DVD to make sure it worked and then burnt a -R disk. Not problems with either.

I should also note that all other backups done with the Plextor burner and Alcohol 120% have all worked! It was only the large game Final Fantasy X (4.2 gigs) that I had a problem with.

So there appears to be no protection that would stop your programs from reading at 50%. It must be an problem with the disk that you are trying to read. Especially if all the programs stop at the same area of the disk!
Not open for further replies.
Top Bottom