cannont connect

vicious pete

Beta member
Messages
3
hey im having a problem connecting to the internet with one of my desktops. I have it so that it automatically receives an ip address. It receives only a class b private address and a subnet. Ive pinged my nic and it is in perfect working order. But for some reason i am not able to connect to the internet. I know its not my Ethernet cable because i can access the internet with my laptop but it doesn't work when i connect it to my desktop.

Any help on how to get my connection up and running would be appreciated.
 

Raffaz

Golden Master
Messages
6,798
Whats the ip address your receiving? Its not 169.254.x.x by any chance, is it? If it is then your getting an APIPA address which means your having a problem with the DHCP server.
 

vicious pete

Beta member
Messages
3
i am getting a 169.254.x.x automatic private address, and a class b subnet. Is there something i could do to fix it?
 

Raffaz

Golden Master
Messages
6,798
So its a DHCP problem then. For some reason you cant connect to the DHCP server, it could be a connection problem, or a configuration problem. Try running the network diagnostics tool, instructions below.

1. Click Start, and then click Help and Support.
2. Click the link to Use Tools to view your computer information and diagnose problems, and then click Network Diagnostics in the list on the left.
3. When you click Scan your system, Network Diagnostics gathers configuration information and performs automated troubleshooting of the network connection.
4. When the process is completed, look for any items that are marked "FAILED" in red, expand those categories, and then view the additional details about what the testing showed.

If this doesnt solve it, then post the areas that the computer failed on.
 

vicious pete

Beta member
Messages
3
I passed the network adapters part but when I click on it to view all the information it says-

Caption = [00000001] SMC EZ Card 10/100 PCI (SMC1211TX)
DatabasePath = %SystemRoot%\System32\drivers\etc
Description = SMC EZ Card 10/100 PCI (SMC1211TX) - Packet Scheduler Miniport
DHCPEnabled = TRUE
DHCPLeaseExpires = 9:14:07 PM 1/18/2038 <--- this looks weird expires 2038?
DHCPLeaseObtained = 10:18:01 AM 3/17/2007
DHCPServer = 255.255.255.255 (Invalid IP Address)
DNsEnabledForWINSResolution = FALSE
DNSHostName = peter
FullDNSRegistrationEnabled = True
Index = 1
IPAddress = 169.254.x.x (PASSED)
IPConnectionMetric = 20
IPEnabled = TRUE
IPFilterSecurityEnabled = FALSE
IPSubnet = 255.255.0.0
IPXEnabled = FALSE
MACAddress = (numbers and digits)
ServiceName = (6 numbers and digits)
SettingID = {bunch of letters and number}
TcpipNetbiosOptions = 0
WINSEnableLMHostsLookup = TRUE


(i didnt post the mac, setting id, or the service name- dont think u need that)
 
Top