blank monitor when powering up

Status
Not open for further replies.

rtc0000

Solid State Member
Messages
7
hi ive been having a problem and am trying to figure out whats going on, i have a Amd sempron 2400 processor, asrock k7s41gx mobo, gforce fx 5200 256 agp vid card, 1k kingston ram, and a hydro 400 watt power supply

the problem I am having is when i power up, all the fans turn and the cdrom and hd are going but i get nothing but a blank screen on my monitor, my wife usually uses this comp when she plays eq2 on it and she has noticed the screen flicker a few times in the last week and we thought maybe the monitor was going, so far i know the monitor is good and the hard drive is good, the vid card havent tested yet but i tried to boot the comp off the board vid and still nothing, ive tried resetting the bios by taking the battery out and still no screen while powering up, any ideas out there what may be the problem would be greatly appreciated.
 

sr5

Baseband Member
Messages
32
Has this just happened all of a sudden? or were u doing some upgrading and then this occurred?

Check to see if u can see any burnt areas on the mobo.
 

rtc0000

Solid State Member
Messages
7
this happened all of the sudden, never had any problems before with this comp but now im at a loss to whats wrong i was guessing at first power supply but someone else told me it was most likely the processor if when i cleared the cmos by removing the battery if i didnt get the bios screen then.
 

rtc0000

Solid State Member
Messages
7
nope blank screen is all i have everything kicks on and seems to be normal just no output on the screen at all and no beeps, i hate to take it to a tech shop but i may do so, is there anyway after taking the processor out that you can tell if its bad, ive looked all over the mobo and i havent seen any burn spots on it
 

sr5

Baseband Member
Messages
32
Does your fan on your processor spin,(could be an indication that it could of died if it was not spinning)

If u remove your processor, and sometimes if there is discoloration it could be dead, but sometimes it could be dead without any discoloration.
 

daappleby

Daemon Poster
Messages
584
pull one stick or ram out and try again, if that still doesnt work put the other one in, try both slots with each peice to see if you have a bad ram stick. You really should try a known good vid card first though.
 

rtc0000

Solid State Member
Messages
7
yeah the processer fan moves once you power up i havent attempted to take it out yet.
 
Status
Not open for further replies.
Top