ASUS Eee PC 1005HAB keyboard not working properly

Zekester2015

In Runtime
Messages
307
Location
Missouri, USA
OK, for over a month now, my ASUS Eee PC 1005HAB 's keyboard hasn't been working properly... The "S", "," and "m" key don't work when I press it, but the "S" key freaks out and keeps repeating sometimes.. Whenever I put it into sleep mode, It just wakes back up after a few seconds..... I unplugged the keyboard and tried wiping off the connector, no luck... How could I fix this??? (I am currently thinking of buying a new one off Ebay, but I don't want to, if this can be fixed.....)
 

carnageX

Private Joker,
Staff member
Messages
25,020
Location
South Dakota
Have you checked if it's a software issue rather than a hardware issue?

You could try booting off of a Linux LiveCD (such as Ubuntu) and see if the issue persists across the Live environment - if it does, then it's hardware and you'll have to replace it. If it works fine, then it's a software/driver issue.
 

Zekester2015

In Runtime
Messages
307
Location
Missouri, USA
It is a hardware problem. I tried using my MS-DOS disk, and as soon as the command line showed up, it showed "sssssssssssssssssssss"
so, It must be a hardware issue...
 

donetao

Banned
Messages
1,158
Location
Enid Oklahoma
Hi It sounds like you know where your problem is. You just want to know if there's a fix for the key board. After a little research on the web, it sounds like ASUS is noted for your kind of problem. I really couldn't find a fix, so a new KB or the USB KB????
Gary!
PS I did see where a loose connection caused problems. You might check that out!!
 
Last edited:

carnageX

Private Joker,
Staff member
Messages
25,020
Location
South Dakota
It is a hardware problem. I tried using my MS-DOS disk, and as soon as the command line showed up, it showed "sssssssssssssssssssss"
so, It must be a hardware issue...
Welp, there's your answer then ;). Suggest replacing it or sticking with your USB keyboard.
 
Top