Techist - Tech Forum - Search Results

Go Back   Techist - Tech Forum > Search Forums
Click Here to Login
Showing results 1 to 4 of 4
Search took 0.00 seconds.
Search: Posts Made By: maximus44
Forum: Hardware Repairs and Troubleshooting 10-22-2009, 06:16 AM
Replies: 8
Views: 877
Posted By maximus44
Re: Performance Issues and general slowness

Hey,
Tried ccleaner and clearing out temp as suggested, but no improvement so far. I have tried using seatools to check the harddrives, but it fails to run. Any ideas?
Forum: Overclocking and Modding 10-20-2009, 06:58 AM
Replies: 0
Views: 1,418
Posted By maximus44
Poor PC Performance

Hi everyone, I've had this computer to close to a year now, and I have been trying to understand why it has been struggling to run games and other general tasks. I brought a graphics card with the...
Forum: Hardware Repairs and Troubleshooting 10-19-2009, 05:41 AM
Replies: 8
Views: 877
Posted By maximus44
Performance Issues and general slowness

Hi everyone, I've had this computer to close to a year now, and I have been trying to understand why it has been struggling to run games and other general tasks. I brought a graphics card with the...
Forum: New Member Introductions 10-19-2009, 04:10 AM
Replies: 1
Views: 499
Posted By maximus44
Howdy

Hey everybody! Please be nice to PC simpletons like me! :tongue:
Showing results 1 to 4 of 4

 
Forum Jump


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.