Windows XP - default gateway.. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 08-10-2006, 01:11 PM   #1 (permalink)
Newb Techie
 
Join Date: Aug 2006
Posts: 3
Default Windows XP - default gateway..

Hello.

I have two ethernetcards, with static IPs assigned, and those interfaces uses two different gateways.

The gateways use the same metric (30), and I need them both to have 30. (for certain reasons)

The problem is, since the two gateways are on the same metric, windows tends to switch the default gateway, on random occassions.
I need the default gateway, to stay the same, without increasing/decreasing the metric for one of the gateways.

Any ideas ?
Thanks.

Regards,
Patrik, Sweden
__________________

marulk2 is offline  
Old 08-10-2006, 01:55 PM   #2 (permalink)
Law
Wizard Techie
 
Law's Avatar
 
Join Date: Aug 2005
Location: the data closet
Posts: 4,200
Default

Hello marulk2,

This Automatic metric is enable by default, you'll have to disable it in the advanced section of the TCP/IP protocol.

Go to Control Panel/Network Connection, right click on the adapter you want to modify and select Properties. Double click on TCP/IP and select the advanced button on the bottom right. In the Default Gateways section, select the one you want and click edit and specify your own metric.

Is this what you are looking for?

Or you can disable the automatic metric for the LAN, the setting is just below the default gateway section.
__________________

Law is offline  
Old 08-10-2006, 02:52 PM   #3 (permalink)
Newb Techie
 
Join Date: Aug 2006
Posts: 3
Default

Thanks for your reply.

yeah, I know I can set the metric manually, but I still need the metric to be "30". So if I set the metric manually, I need to set it to 30 on both interfaces anyhow.

So the question remains, how do I "lock" the default gateway to one address, if there is two gateways on the same metric.

//Patrik
marulk2 is offline  
Old 08-10-2006, 03:28 PM   #4 (permalink)
Law
Wizard Techie
 
Law's Avatar
 
Join Date: Aug 2005
Location: the data closet
Posts: 4,200
Default

I know what you are trying to do now, but I'm still trying to look into the problem myself. I don't think you can do that, if you have two default gateway on 1 adapter, then the obvious solution is to lower one of the metric but this isn't the case for you since you want both to be 30 but still use a particular one. I don't know if the order of the default gateway will matter in this situation.

Here's where I'm reading it from
http://www.microsoft.com/technet/com...uy/cg0903.mspx

Read the part about the "Dead Gateway Detection" also. This is the thing that probably cause it to keep switching.

I guess what M$ was saying is that in Windows XP when there are multiple default route in the routing table with the lowest metric, TCP/IP for Windows XP and Windows Server 2003 uses the default route corresponding to the adapter that is the highest in the binding order. You can view this order by going to Control Panel/Network Connection. Select the Advanced menu on the top and select Advanced Setting. The binding order is listed in "Adapters and Bindings" tab. Not sure if this is it, but since a default gateway and default route are two different things use interchangeably
Law is offline  
Old 08-10-2006, 03:39 PM   #5 (permalink)
Law
Wizard Techie
 
Law's Avatar
 
Join Date: Aug 2005
Location: the data closet
Posts: 4,200
Default

I don't know if you should do this but you can disable the "Dead Gateway Detection" feature for the TCP/IP.

Open up your registry, make sure you back up the registry first by going to File-Export.

Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\Tcpip\Parameters\Interfaces\*

* Being the right folder under it, you can tell which one is the interface by the IP information listed in them. You'll see the entry EnableDeadGWDetect. Set the value data to 0 to disable it.
Law is offline  
Old 08-10-2006, 04:47 PM   #6 (permalink)
Newb Techie
 
Join Date: Aug 2006
Posts: 3
Default

That might do the trick !

Thank you very much

//Patrik
__________________

marulk2 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.