Windows will not Assign a Drive Letter to my CD-Rom - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 01-14-2006, 04:44 PM   #1 (permalink)
Newb Techie
 
Join Date: Jan 2006
Posts: 2
Default Windows will not Assign a Drive Letter to my CD-Rom

OK I think this is a tough one. I'm working on a customer's Win98SE computer that had lots of malware which has now all been removed successfully. I noticed his CD-rom drives didn't show up in "My Computer" so I went through some standard troubleshooting steps. Drives are recognized in Bios AND in Device Manager. I've swapped out with other drives same problem. I've changed his IDE controller settings to "Both IDE channels enabled." I've tried uninstalling the drives to let Windows re-install on reboot. No change. Yet I booted up his computer with a BartPE disc no problem. So I don't think it could be a hardware problem.

I've also tried changing the "reserved drive letters" for the cd-roms (in device manager) but still no change. When I reboot Windows will still not assign a drive letter even though the drives are recognized and working properly. Any ideas?

Thanks in advance for any help or suggestions.
__________________

himini is offline  
Old 01-14-2006, 05:14 PM   #2 (permalink)
Techie Beyond Description
 
Osiris's Avatar
 
Join Date: Jan 2005
Location: Kentucky
Posts: 36,817
Send a message via ICQ to Osiris Send a message via AIM to Osiris Send a message via MSN to Osiris Send a message via Yahoo to Osiris
Default

1. Click Start, and then click Run.
2. In the Open box, type regedit, and then click OK.
3. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Class/{4d36e965-e325-11ce-bfc1-08002be10318}
4. On the File menu, click Export.
5. In the File name box, type savedkey, and then click Save.
6. Click the REG_MULTI_SZ data type UpperFilters, and then click Delete on the Edit menu. When you are prompted to confirm the deletion, click Yes.

Note If this data type is missing, go to Method 2.
7. Click the REG_MULTI_SZ data type LowerFilters, and then click Delete on the Edit menu. When you are prompted to confirm the deletion, click Yes.
8. Quit Registry Editor, and then restart the computer.
__________________

__________________
Osiris is offline  
Old 01-14-2006, 06:15 PM   #3 (permalink)
Newb Techie
 
Join Date: Jan 2006
Posts: 2
Default

Thanks for the response. I did just try this method before your post (Microsoft article Q320553-- http://support.microsoft.com/kb/320553/) but no such key exists in the Win98 registry. There is no "class" under "control." There is a "class" under "services" that has the "{4d36e965-e325-11ce-bfc1-08002be10318}" but there is no "REG_MULTI_SZ data type" here.

Thanks again for any help.
himini is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.