USB not working - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Closed Thread
Thread Tools Display Modes
Old 05-22-2004, 08:51 AM   #1 (permalink)
Newb Techie
Join Date: May 2004
Posts: 14
Default USB not working

I have recently bought a digital camera and have installed the correct drivers yet the PC is not detecting it. Do I have to enable my usb ports to make it work? How do i do this? Many thanks.

vilejames is offline  
Old 05-22-2004, 12:26 PM   #2 (permalink)
Newb Techie
Join Date: May 2004
Posts: 5
Default Are you sure

Are you sure everything is hooked up right, sure its not the usb port, sure its not the usb cable... sure the its not the camera? Also try uninstalling the drivers and reinstalling them. Also are you using the software that came with the camera... it could be any of those things. Also you could try uninstalling and reinstalling the usb ports.

carnageblender is offline  
Old 05-22-2004, 03:47 PM   #3 (permalink)
HONK if you route packets
mikesgroovin's Avatar
Join Date: Sep 2003
Location: MD
Posts: 4,715

Yes, make sure that the cable is connected properly, the camera is turned on and the USB ports are active.

mikesgroovin is offline  
Old 05-22-2004, 08:10 PM   #4 (permalink)
Master Techie
Join Date: Feb 2004
Posts: 2,172
Send a message via AIM to Win2kpatcher

Yep as mentioned it is important the camera is turned on. Many of the cases I deal with cameras not working with the PC via USB port is because the camera was off during install or when ready to use it after the software was installed.

If you have an OS after win 98 you will get a little pop up that says Detected new USB device then prompt you to install the software, did that ever appear?
Win2kpatcher is offline  
Old 05-22-2004, 08:32 PM   #5 (permalink)
Newb Techie
Join Date: May 2004
Posts: 12

I think is ur USB port got problem. Because last time i also bought a digital camera and the PC also cannot detect my camera, after that i changed a USB port (PCI Card), then the problem will be resolved. Your USB port is it PCI card?
okboy is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.