Unidirectional Network Sharing - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 09-15-2005, 09:26 PM   #1 (permalink)
Junior Techie
 
Join Date: Sep 2005
Posts: 72
Default Unidirectional Network Sharing

Hi

I've had this problem forever. I am running Windows XP pro on my desktop, and XP home on my laptop. When trying to share files, my laptop "sees" all my shared folders on my desktop and works perfectly. My desktop computer "sees" the laptop in my network places but if I try to access it, it tells me:

"[Computer name] is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permission. The network path was not found"

Same result if trying to connect by IP. In the command prompt, a net view, shows the the computer (\\Inspiron_1150), but I can not ping it. (And of course I have file sharing of folders enabled on the laptop). I can ping from my laptop to the desktop sucessfully.

I have gone through the network wizard and selected the choice "This computer connects to a network that does not have an internet connection" (which is the only option that lets sharing work with other computers) even though it does have internet.

Anyone know why my connection only works one way??

(Please only responses relevent to solving this specific problem. Thanks!)
__________________

xr280xr is offline  
Old 09-15-2005, 09:37 PM   #2 (permalink)
Techie Beyond Description
 
Osiris's Avatar
 
Join Date: Jan 2005
Location: Kentucky
Posts: 36,817
Send a message via ICQ to Osiris Send a message via AIM to Osiris Send a message via MSN to Osiris Send a message via Yahoo to Osiris
Default

XP home has a default built in security thing. It's weird and difficult to work with. Make sure the directories that you are sharing don't fall within c:\documents and settings\any user name. If they are not in there then right click on the folder and go to properties Check the sharing and security tab to verify permissions.
__________________

__________________
Osiris is offline  
Old 09-15-2005, 09:45 PM   #3 (permalink)
Junior Techie
 
Join Date: Sep 2005
Posts: 72
Default

The folder is under my username (my documents) what do I have to do to share this folder. If i turn off mcaffee firewall, it allows me to attempt to log in under the guest account which is disabled. If I turn it on and remove the password the sharing works, but I don't want to have the guest account on (I don't have it active on my desktop computer and I can share files just fine). I'm only familiar with networking on NT where you define users and permissions. Can you tell me more about how it works on xp? Thanks!
xr280xr is offline  
Old 09-15-2005, 09:46 PM   #4 (permalink)
Junior Techie
 
Join Date: Sep 2005
Posts: 72
Default

I forgot to ask, do I open a port on the firewall or something? Cause it seems to be blocking the filesharing.
xr280xr is offline  
Old 09-15-2005, 09:49 PM   #5 (permalink)
Techie Beyond Description
 
Osiris's Avatar
 
Join Date: Jan 2005
Location: Kentucky
Posts: 36,817
Send a message via ICQ to Osiris Send a message via AIM to Osiris Send a message via MSN to Osiris Send a message via Yahoo to Osiris
Default

Did you turn off XPs firewall? Try using no FW's and see if you can ping it and access it. Did you allow the connection in Mcafee? Zone Alarm always asks me about a new connection when Im networked
__________________
Osiris is offline  
Old 09-15-2005, 10:05 PM   #6 (permalink)
Junior Techie
 
Join Date: Sep 2005
Posts: 72
Default

Very strange. I'm gonna take you through the steps from when I first posted this thread:

1. On the laptop, Mcaffee personal firewall was on, Guest account was off and password protected. Windows firewall was on.

2. I turned off Mcaffee firewall and tried accessing the computer. It gave me a logon password window under the guest account (which was the only option for user) but I did not know the password.

3. Removed password from guest user account. Tried accessing computer, and it worked.

4. Turned windows firewall back on, still worked (pings and all).

5. Tried to put the guest password back on, but there is no option to do this (do you know how you add one?).

6. Turned McAfee firewall back on...could not access it.

Clearly the password was needed before, and McAfee is blocking it. I do not know how to allow it though, it only gives me the option of allowing applications or ports and only notifies me of new connections for outgoing connections. So...open a certain port?
xr280xr is offline  
Old 09-15-2005, 10:06 PM   #7 (permalink)
Junior Techie
 
Join Date: Sep 2005
Posts: 72
Default

Sorry forgot,

Step 5.5. Turned guest account back off and still works.
xr280xr is offline  
Old 09-15-2005, 10:38 PM   #8 (permalink)
Chillin Techie
 
Join Date: Nov 2004
Location: USA
Posts: 11,861
Default

ipconfig the working computer and manually enter that ip in mcaffee or unistall mcaffee

some 3rd party firewalls will give networks fits. make sure they are disable (preferably uninstalled) when you run the wizard as the true vector part will still try to block the ports

most 3rd party firewalls will recognize an already installed properly communicated network
__________________
The Ultimate Hard Drive Utility PowerMax 4.23. (It now has the ability to clean a Boot Sector virus on the quick erase option.)
The best browser Netscape 8
Have you accidently delete something? Look here (trial. the better one) and here(free)
EricB is offline  
Old 09-15-2005, 11:09 PM   #9 (permalink)
Junior Techie
 
Join Date: Sep 2005
Posts: 72
Default

Awesome thanks. To sum up I just had to remove the password from the guest account beceause apparently windows uses the guest account for file sharing whether it's enabled or not, and tell McAfee to trust all traffic on my network. Thanks for your help!
__________________

xr280xr is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.