Sound drivers for new xp installation? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Closed Thread
Thread Tools Display Modes
Old 06-24-2007, 11:18 PM   #1 (permalink)
Super Techie
Join Date: Jul 2006
Posts: 283
Default Sound drivers for new xp installation?

I recently installed windows xp pro, and attempted to install film editing software. The software complains of a lack of sound drivers.

Where do I find sound drivers to download? Or any hardware drivers for a new installation?

darsunt is offline  
Old 06-24-2007, 11:21 PM   #2 (permalink)
Call me Mak or K
Mod Emeritus
KSoD's Avatar
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: Sound drivers for new xp installation?

Download CPUz and run it. From there get the make of your mother board. From there use Google to find the make and model.

After you got all that google for the drivers of the motherboard.

If it is a Dell or HP or some other system. Go to their site. They should have drivers available. Also have you tried Windows Update to get the necessary drivers?

I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 06-27-2007, 11:07 PM   #3 (permalink)
Chillin Techie
Join Date: Nov 2004
Location: USA
Posts: 11,861
Default Re: Sound drivers for new xp installation?

install everest. it will name the driver
The Ultimate Hard Drive Utility PowerMax 4.23. (It now has the ability to clean a Boot Sector virus on the quick erase option.)
The best browser Netscape 8
Have you accidently delete something? Look here (trial. the better one) and here(free)
EricB is offline  
Old 06-28-2007, 10:47 AM   #4 (permalink)
Ultra Techie
Join Date: Dec 2006
Location: Liverpool, UK
Posts: 511
Default Re: Sound drivers for new xp installation?

Everest I would use, easy to use. Never used CPUz though.
HAF 932 -- ASUS P8Z68-V
Intel i5 @ 4.5Ghz -- CoolerMaster Hyper 212 Plus
8GB Corsair Vengeance Jet Black 1600MHz -- 2x XFX ATi Radeon HD 6970 2GB
Raze664 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Did my sound card die on me?? :( Nuggets Hardware Repairs and Troubleshooting 5 06-13-2007 11:17 AM
Sound Card Issues!! Nuggets Computer Audio and Multimedia 1 06-12-2007 08:40 PM
Can't use onboard sound for P5B-VM goo_lu Hardware Repairs and Troubleshooting 5 05-29-2007 01:39 PM
Mysterious Sound Problem PartySized Computer Audio and Multimedia 4 04-13-2007 03:55 AM
Sound Issues on Striker Extreme, Drivers won't install Alexinator New Systems | Building and Buying 3 04-01-2007 09:03 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:04 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.