Setting the default bootable OS - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 08-17-2005, 11:39 AM   #1 (permalink)
Newb Techie
 
Join Date: Jan 2005
Posts: 6
Default Setting the default bootable OS

Ok, I have Win XP installed on my C:\, as well as my D:\. So, when I boot my computer it gives me the option of which OS to load, and the first one will default (C:\) after about 30 seconds. All is fine....

BUT, the other day I went to install a fresh copy of Win XP over my D:\ because of driver incompatibilities and got about half way through and realized that if I did a fresh install, I would lose all of My Documents and other files I had not backed up. SO, I canceled the install and decided that I didn't need a fresh copy of Win XP on my D:\ because I don't use it that often.

SO NOW, when I boot my computer I have THREE options: the first one being my OS for C:\, the second one being my old copy OS on my D:\, and now the newly created OS for my D:\. The problem is, the third (the one where I tried to install a fresh copy of WinXP to my D:\) is now the default. So, if my computer restarts and I am not there to choose which OS I want, it defaults to the third installation which results in a failed load and I have to restart again and choose one of the first two.

SO, I went into the file where it shows the boot lines (I forget which one it is, boot.ini?) and deleted the third line (which was the third OS I tried to load) but it is still showing that I have a third OS installed when I boot my computer. These are the three options of OS that I get:

1. Windows XP Professional (C:\)
2. Windows XP Professional (original copy on D:\)
3. Default

...In those exact words. It defaults to number 3 unless I am there to manually choose number one. Is there a way to get rid of 3?

Thanks guys, sorry for the rambling.
__________________

bound4h is offline  
Old 08-17-2005, 12:17 PM   #2 (permalink)
Ultra Techie
 
Join Date: Jul 2005
Posts: 813
Default

Last week someone else had this exact same problem and couldn't fix it by modifying the boot.ini

He did fix it but I can't remember how, I will try and remembers the posters name and take a look around for the thread, give me a bit.
__________________

__________________
Associates Degree in IS

A+ Certified

Studying for Network+
BASSMASTER is offline  
Old 08-17-2005, 12:17 PM   #3 (permalink)
It's all just 1s and 0s
 
office politics's Avatar
 
Join Date: Jan 2004
Location: in the lab
Posts: 6,555
Send a message via MSN to office politics
Default

would you please post the data contained within C:\boot.ini
office politics is offline  
Old 08-17-2005, 12:20 PM   #4 (permalink)
Ultra Techie
 
Join Date: Jul 2005
Posts: 813
Default

I found the thread, here is the solution this other person found:

Editing the boot.ini file accomplished nothing. I had to boot from the XP cd and enter recovery console : went to bootcfg /fixboot and and selected the primary os boot from there and..................done deal
__________________
Associates Degree in IS

A+ Certified

Studying for Network+
BASSMASTER is offline  
Old 08-17-2005, 12:25 PM   #5 (permalink)
Newb Techie
 
Join Date: Jan 2005
Posts: 6
Default

Great thanks~!
bound4h is offline  
Old 08-18-2005, 07:05 AM   #6 (permalink)
Junior Techie
 
Join Date: Aug 2005
Posts: 46
Default

when u fall in such a problems always use recovery console
__________________

aniket is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.