Razer Copperhead Firmware, need drivers/location - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-15-2006, 12:06 AM   #1 (permalink)
Super Techie
 
Join Date: May 2005
Posts: 267
Send a message via AIM to Biggie578
Default Razer Copperhead Firmware, need drivers/location

Im trying to update my copperhead's firmware and when i unplugged it and plugged back while holding the profile button like it told me to, when i plugged it back in it found new hardware and needs a driver for it. The guide on razer's site told me that this would happen and to just point it to my driver, but i dont know where that is. I tried pointing it to the folder where i extraxted the driver archive from razer. Im assuming that the hardware wizard is looking for an .inf and in the driver archive/folder from razer theres a setup.exe and Data1.cab Data2.cab and some other files. The CD that came with the mouse has the same files. The only other thing that I can think of is to go to the main windows "collection" of .inf driver files, but I dont know where that is. Any help would be appreciated.
__________________

Biggie578 is offline  
Old 12-15-2006, 01:21 AM   #2 (permalink)
Grandfather of Techist

\_(ツ)_/
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,307
Default

Download the drivers again (or the first time). Install them like it says... just make sure to note the location it is to be installed to.

That way, you have the latest drivers and firmware, and you know where it is.

http://www.razersupport.com/
__________________

__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is offline  
Old 12-15-2006, 07:32 AM   #3 (permalink)
Super Techie
 
Join Date: May 2005
Posts: 267
Send a message via AIM to Biggie578
Default

o werd, it installed to program files, lemme try there. I cant really reboot right now...

Ok, that didnt work

btw, if it matters, my windows drive where I install programs and stuff if I:
Biggie578 is offline  
Old 12-15-2006, 02:34 PM   #4 (permalink)
Grandfather of Techist

\_(ツ)_/
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,307
Default

Try pointing to where you downloaded it to.
__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is offline  
Old 12-15-2006, 04:49 PM   #5 (permalink)
Super Techie
 
Join Date: May 2005
Posts: 267
Send a message via AIM to Biggie578
Default

what i downloaded was a .zip and it has:

autorun.exe
autorun.inf
data1.cab
data1.hdr
data2.cab
ikernel.ex_
layout.bin
setup.bmp
setup.exe
setup.ini
setup.inx

and the firmware file that i downloaded sepreatly is "Version 0618.s19

I tried automatic installation, and "advanced" and tried the extracted folder of what i downloaded, and the folder where i installed the drivers to via the exe above, and the CD. Whats the folder with all of the .inf drivers that windows uses? im convinced that that is what I need.
Biggie578 is offline  
Old 12-15-2006, 05:12 PM   #6 (permalink)
Grandfather of Techist

\_(ツ)_/
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,307
Default

For you, it should be:
I:/Program Files/Razer/Driver
__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is offline  
Old 12-15-2006, 05:32 PM   #7 (permalink)
Super Techie
 
Join Date: May 2005
Posts: 267
Send a message via AIM to Biggie578
Default

yeah, no luck even tho the /Copperhead/Drivers folder has a "Copperhd.inf" file in it. But its not looking for a copperhead driver. According to the screenshot on the razer website, its a "Freescale USB JW32 ICP Device"

EDIT: Ok i got the drivers i needed here
Biggie578 is offline  
Old 12-15-2006, 11:54 PM   #8 (permalink)
Grandfather of Techist

\_(ツ)_/
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,307
Default

Question: Why did you need the firmware and driver, anyway?
__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is offline  
Old 12-23-2006, 02:54 PM   #9 (permalink)
Super Techie
 
Join Date: May 2005
Posts: 267
Send a message via AIM to Biggie578
Default

i wanted to update firmware to latest version, and in doing so, it found new hardware which it needed drivers for. I found them tho. A file called "USBICP.INF" on some french driver site.
__________________

Biggie578 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.