Random crashes - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 08-05-2005, 04:16 AM   #1 (permalink)
Newb Techie
 
Join Date: Aug 2005
Posts: 2
Default Random crashes

Hi, I just bought some new hardware and installed xp with all the updates and everyonce in a while i get a random crash. I'm including the debugging report from the memory dump. Maybe someone can make sense of it better than I can...Thanks.


Microsoft (R) Windows Debugger Version 6.5.0003.7
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\WINDOWS\Minidump\Mini080405-02.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is: c:\i386
Windows XP Kernel Version 2600 (Service Pack 2) UP Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 2600.xpsp_sp2_gdr.050301-1519
Kernel base = 0x804d7000 PsLoadedModuleList = 0x805531a0
Debug session time: Thu Aug 4 23:30:28.812 2005 (GMT-7)
System Uptime: 0 days 0:24:32.401
Loading Kernel Symbols
.................................................. .................................................. ....................................
Loading unloaded module list
.........
Loading User Symbols
************************************************** *****************************
* *
* Bugcheck Analysis *
* *
************************************************** *****************************

Use !analyze -v to get detailed debugging information.

BugCheck 9C, {4, 80545ff0, b2000000, 70f0f}

Probably caused by : ntkrnlpa.exe ( nt!KdPitchDebugger+ef4 )

Followup: MachineOwner
---------

kd> !analyze -v
************************************************** *****************************
* *
* Bugcheck Analysis *
* *
************************************************** *****************************

MACHINE_CHECK_EXCEPTION (9c)
A fatal Machine Check Exception has occurred.
KeBugCheckEx parameters;
x86 Processors
If the processor has ONLY MCE feature available (For example Intel
Pentium), the parameters are:
1 - Low 32 bits of P5_MC_TYPE MSR
2 - Address of MCA_EXCEPTION structure
3 - High 32 bits of P5_MC_ADDR MSR
4 - Low 32 bits of P5_MC_ADDR MSR
If the processor also has MCA feature available (For example Intel
Pentium Pro), the parameters are:
1 - Bank number
2 - Address of MCA_EXCEPTION structure
3 - High 32 bits of MCi_STATUS MSR for the MCA bank that had the error
4 - Low 32 bits of MCi_STATUS MSR for the MCA bank that had the error
IA64 Processors
1 - Bugcheck Type
1 - MCA_ASSERT
2 - MCA_GET_STATEINFO
SAL returned an error for SAL_GET_STATEINFO while processing MCA.
3 - MCA_CLEAR_STATEINFO
SAL returned an error for SAL_CLEAR_STATEINFO while processing MCA.
4 - MCA_FATAL
FW reported a fatal MCA.
5 - MCA_NONFATAL
SAL reported a recoverable MCA and we don't support currently
support recovery or SAL generated an MCA and then couldn't
produce an error record.
0xB - INIT_ASSERT
0xC - INIT_GET_STATEINFO
SAL returned an error for SAL_GET_STATEINFO while processing INIT event.
0xD - INIT_CLEAR_STATEINFO
SAL returned an error for SAL_CLEAR_STATEINFO while processing INIT event.
0xE - INIT_FATAL
Not used.
2 - Address of log
3 - Size of log
4 - Error code in the case of x_GET_STATEINFO or x_CLEAR_STATEINFO
AMD64 Processors
1 - Bank number
2 - Address of MCA_EXCEPTION structure
3 - High 32 bits of MCi_STATUS MSR for the MCA bank that had the error
4 - Low 32 bits of MCi_STATUS MSR for the MCA bank that had the error
Arguments:
Arg1: 00000004
Arg2: 80545ff0
Arg3: b2000000
Arg4: 00070f0f

Debugging Details:
------------------


BUGCHECK_STR: 0x9C_IA32_AuthenticAMD

CUSTOMER_CRASH_COUNT: 2

DEFAULT_BUCKET_ID: DRIVER_FAULT

LAST_CONTROL_TRANSFER: from 806d38df to 804f8925

SYMBOL_ON_RAW_STACK: 1

STACK_TEXT:
80545fc8 806d38df 0000009c 00000004 80545ff0 nt!KeBugCheckEx+0x1b
80545fc8 00000000 0000009c 00000004 80545ff0 hal!HalpMcaExceptionHandler+0xdd


STACK_COMMAND: dds @$csp ; kb

FOLLOWUP_IP:
nt!KdPitchDebugger+ef4
80545ff0 0100 add [eax],eax

FOLLOWUP_NAME: MachineOwner

SYMBOL_NAME: nt!KdPitchDebugger+ef4

MODULE_NAME: nt

IMAGE_NAME: ntkrnlpa.exe

DEBUG_FLR_IMAGE_TIMESTAMP: 42250a1d

FAILURE_BUCKET_ID: 0x9C_IA32_AuthenticAMD_nt!KdPitchDebugger+ef4

BUCKET_ID: 0x9C_IA32_AuthenticAMD_nt!KdPitchDebugger+ef4

Followup: MachineOwner
---------
__________________

Deej is offline  
Old 08-05-2005, 10:50 AM   #2 (permalink)
Super Techie
 
Join Date: Jun 2005
Posts: 320
Default

Run memtest

If it gives you even 1 error you have bad ram and it needs to be replaced.
__________________

__________________
Grayfox is offline  
Old 08-05-2005, 12:46 PM   #3 (permalink)
Newb Techie
 
Join Date: Aug 2005
Posts: 2
Default

actually you know what.. it seems to happen a lot when i am on the 4th installation cd of world of warcraft installing the sound.mpq... I just successfully installed the game when i was trying xp 64, but i got rid of that crap and went back to xp.

i was running memtest yesterday and was actually getting no errors at 2-2-2-8 and 3.2 volts which is legit for this memory according the manufactor but then went back to defaults and got no errors either runnings tests 5 and 8.
Deej is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.