Problem installing DirectX 9.0c [ Please Help ] - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 09-30-2004, 12:19 AM   #1 (permalink)
Newb Techie
 
Join Date: Apr 2004
Posts: 32
Send a message via AIM to wiseguyz408
Default Problem installing DirectX 9.0c [ Please Help ]

I'm trying to install the new version of Direct X (9.0c), and It keeps failing.

The installation stops when the bar gets to 'sound.dll' and an error comes up saying "An Internal error has occured. Please refer to directx.log in your Windows folder to determine problem."

So, I check directx.log and this is what it says:

09/28/04 18:21:23: dsetup32: === SetupForDirectX() start ===
09/28/04 18:21:23: dsetup32: DXSetupCommand = 0.
09/28/04 18:21:23: DXSetup: DSetupCallback(): Phase = 0, Steps = 0
09/28/04 18:21:23: dsetup32: DirectXSetupIsJapanese == 0
09/28/04 18:21:23: dsetup32: DirectXSetupIsJapanNec == 0
09/28/04 18:21:23: dsetup32: Installing on WinXP SP
09/28/04 18:21:23: dsetup32: Checking the version: HKLM\software\microsoft\directx\Version
09/28/04 18:21:23: dsetup32: Version in registry = 4.09.00.0901
09/28/04 18:21:23: dsetup32: Version in DLL = 4.09.00.0904
09/28/04 18:21:23: dsetup32: Installation Started with language eng
09/28/04 18:21:23: dsetup32: DXCheckTrust(): C:\DOCUME~1\Me\Desktop\WORLDO~1.0EN\DirectX\DXNT.c ab is trusted.
09/28/04 18:21:23: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dxnt.inf from cab
09/28/04 18:21:23: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dxntunp.inf from cab
09/28/04 18:21:23: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dxver.inf from cab
09/28/04 18:21:23: dsetup32: DirectXSetupIsJapanese == 0
09/28/04 18:21:23: dsetup32: DirectXSetupIsJapanNec == 0
09/28/04 18:21:23: dsetup32: DXCheckTrust(): C:\DOCUME~1\Me\Desktop\WORLDO~1.0EN\DirectX\bdaxp. cab is trusted.
09/28/04 18:21:23: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dxbda.inf from cab
09/28/04 18:21:23: dsetup32: DirectXSetupIsJapanese == 0
09/28/04 18:21:23: dsetup32: DirectXSetupIsJapanNec == 0
09/28/04 18:21:27: dsetup32: DoPrecopy: Root path = "null", flags = 0x2010098
09/28/04 18:21:27: dsetup32: RemoveHotfix(): SizeOfPendingFileRenameOperations : 0

09/28/04 18:21:27: dsetup32: RemoveHotfixLoop(): key SOFTWARE\Microsoft\Updates\DirectX\SP1 does not exist.

09/28/04 18:21:27: dsetup32: RemoveHotfix(): SizeOfPendingFileRenameOperations : 0
09/28/04 18:21:27: dsetup32: DoCopy()
09/28/04 18:21:27: dsetup32: Checking the version: HKLM\software\microsoft\directx\Version
09/28/04 18:21:27: dsetup32: Version in registry = 4.09.00.0901
09/28/04 18:21:27: dsetup32: Version in DLL = 4.09.00.0904
09/28/04 18:21:27: DXSetup: DSetupCallback(): Phase = 1, Steps = 174
09/28/04 18:21:27: dsetup32: DoCopy(): Iterating through C:\DOCUME~1\Me\Desktop\WORLDO~1.0EN\DirectX\DXNT.c ab
09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\d3dim700.dll from cab
09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\ddraw.dll from cab
09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\ddrawex.dll from cab
09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dinput.dll from cab
09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dinput.xpg from cab
09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dplaysvr.exe from cab
09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dplayx.dll from cab
09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dpmodemx.dll from cab
09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dpwsockx.dll from cab
09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dsound.dll from cab
09/28/04 18:21:27: dsetup32: DoCopy(): Iterating failed, error = 2.
09/28/04 18:21:27: dsetup32: SetupForDirectX: Restoring Backups
09/28/04 18:21:28: dsetup32: Installation ended with value -9 = Internal or unsupported error
09/28/04 18:22:31: DXSetup: WM_APP_ENDINSTALL
09/28/04 18:22:31: DXSetup: ~CDXWSetup()

A) What does this all mean?
B) How can I fix this?


Thanks a lot.
__________________

wiseguyz408 is offline  
Old 09-30-2004, 02:02 AM   #2 (permalink)
Ultra Techie
 
Join Date: Nov 2003
Posts: 506
Default

If it was from a fresh download, you might have had a corrupted file. Try downloading it again and redo it.
__________________

__________________
My gaming machine:

P4 2.8 GHz
2 X 512 MHz PC3200 in dual DDR mode
Intel D865PERL MOBO
integrated 6.1 MAX audio
Logitech duo MX mouse and KB
ATI RADEON 9800 PRO
zerozero is offline  
Old 09-30-2004, 04:23 AM   #3 (permalink)
Monster Techie
 
Join Date: Jul 2004
Location: Manchester, UK
Posts: 1,909
Default

do you have SP1 installed on your machine?

secondaly, update your audio drivers. as LOG is showing problem occuring installing sound libraries:

copying:

09/28/04 18:21:27: dsetup32: Extracted file C:\WINDOWS\System32\DirectX\DX10.tmp\dsound.dll from cab
09/28/04 18:21:27: dsetup32: DoCopy(): Iterating failed, error = 2.

try again after re-installing sound card drivers, and in case still doesnt works, then shut down every application running from windows task manager, and try again.
__________________
Intel Core2Quad 2.66Ghz 12MB L2-Cache
4096MB DDR Kingston Hyper-X
GigaByte GA-P35-DS3R
XFX 9600GT AlphaDog
Seagate 2 X 320GB SATA2
LG L246WH Flatron 24"
Sony DVD-RW
Blind_Arrow is offline  
Old 09-30-2004, 03:53 PM   #4 (permalink)
Newb Techie
 
Join Date: Apr 2004
Posts: 32
Send a message via AIM to wiseguyz408
Default

Thanks for replying,

Yes, I have SP1 on my machine, running Windows XP.

Where can I get my updated audio driver.. I thought I went to the right page, but there was an error installing the driver I downloaded, so that didnt work. It probably isn't the right driver.

(From running dxdiag.exe )
Device
Name: SoundMAX Digital Audio
Device ID: PCI\VEN_8086DEV_24D5SUBSYS_01551028REV_0
Manufacturer ID: 1
Product ID: 100
Type: WDM
Default Device: Yes

Drivers
Name: smwdm.sys
Version: 5.12.0001.3555
Provider: Analog Devices

As I'm sure you've assumed, I'm not very computer savvy...
Anyways, I went to soundmax.com and they said to get the driver from Dell, so I filled out all the info i could, and I saw one driver that had Analog Devices in it, and d/l that. Probably the wrong one... anyways, that failed to install >_<

Sooo.. yeah, that's where I am now.


Any more advice on what to do?
wiseguyz408 is offline  
Old 10-01-2004, 07:56 AM   #5 (permalink)
Newb Techie
 
Join Date: Apr 2004
Posts: 32
Send a message via AIM to wiseguyz408
Exclamation

ANyone?
wiseguyz408 is offline  
Old 10-01-2004, 08:43 AM   #6 (permalink)
Banned
 
Join Date: Oct 2004
Posts: 422
Default

take your side door off. look for the actual sound chip. get the name there

go to that website to get the latest drivers
__________________

vance43211 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.