PCI cards (Video card + Video Card) not being recognized after fresh install of XP - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-05-2008, 01:48 PM   #1 (permalink)
Newb Techie
 
Join Date: Dec 2008
Posts: 3
Default PCI cards (Video card + Video Card) not being recognized after fresh install of XP

Hey guys, I've been having a problem with my uncle's computer. I've low level formatted his HD because his kid messed up the comp pretty bad. I did a fresh install of XP PRO, but for some reason his PCI cards aren't being recognized.

I've installed the drivers of his mobo, an ECS k7s5a (which I got from the MB's site here) From that list of drivers I've installed the ethernet and agp drivers. I was wondering if I should even install the AGP drivers since his video card is PCI, but I went ahead and did it anyway.

Ok so here's my problem. When I tried to install the sound blaster audigy drivers for his sound card the installer package says "A SB device is not detected." I then go to device manager and both his vid card and sound card are under the "Other Devices" section (the one with the yellow question mark).

As for the video card when I tried to install the drivers from my own comp they basically do nothing, but they don't mess up the display. However when I go to Nvidia and download the supposed "proper" drivers for the card all **** breaks loose. His display is reduced to the lowest settings and barely anything is legible. However the videocard is now being recognized by the device manage as a display driver. But at the same time I can't restore the display back to normal.

Should I just do another low level reformat? I've done it twice now and have gotten no luck. I'm pretty sure the PCI cards aren't being recognized because the drivers aren't installed, but when I do try to install them they either won't install (sound card case) or makes the problem worse (vid card case turning everything to lowest settings).

Any help would be greatly appreciated, thnx fellas.

Here are the comp specs:

ECS k7s5a motherboard
Seagate 120 GB HDD
3D Fuzion GeForce FX 5500 - link
Sound Blaster Audigy - link
__________________

__________________
GMEN316 is offline  
Old 12-05-2008, 02:00 PM   #2 (permalink)
Chillin Techie
 
Join Date: Nov 2004
Location: USA
Posts: 11,861
Default Re: PCI cards (Video card + Video Card) not being recognized after fresh install of X

NVIDIA latest driver has a tendency to do that. go to device manager properties and roll back to the last driver and go to windows update and get their certified driver.

as far the sound card, disable the onboard one in the bios then install the creative one
__________________

__________________
The Ultimate Hard Drive Utility PowerMax 4.23. (It now has the ability to clean a Boot Sector virus on the quick erase option.)
The best browser Netscape 8
Have you accidently delete something? Look here (trial. the better one) and here(free)
EricB is offline  
Old 12-05-2008, 02:09 PM   #3 (permalink)
Newb Techie
 
Join Date: Dec 2008
Posts: 3
Default Re: PCI cards (Video card + Video Card) not being recognized after fresh install of X

Quote:
Originally Posted by EricB View Post
NVIDIA latest driver has a tendency to do that. go to device manager properties and roll back to the last driver and go to windows update and get their certified driver.
I didn't know that about the latest drivers. I don't think I'll be able to get the windows certified drivers since the XP Pro copy I put in isn't a genuine one. Is there another way of getting those drivers without going to the windows update? If not do you know of any working drivers for the FX 5500 model?

Quote:
Originally Posted by EricB View Post
as far the sound card, disable the onboard one in the bios then install the creative one
Where in the bios would that be located in? And by install the creative one you mean install the creative SB driver after I've disabled the on board one right? Thnx.
__________________
GMEN316 is offline  
Old 12-05-2008, 02:16 PM   #4 (permalink)
Chillin Techie
 
Join Date: Nov 2004
Location: USA
Posts: 11,861
Default Re: PCI cards (Video card + Video Card) not being recognized after fresh install of X

go to driverpacks.net and get the drivers

http://www.techist.com/forums/f9/how...rivers-182727/
__________________
The Ultimate Hard Drive Utility PowerMax 4.23. (It now has the ability to clean a Boot Sector virus on the quick erase option.)
The best browser Netscape 8
Have you accidently delete something? Look here (trial. the better one) and here(free)
EricB is offline  
Old 12-05-2008, 03:53 PM   #5 (permalink)
Newb Techie
 
Join Date: Dec 2008
Posts: 3
Default Re: PCI cards (Video card + Video Card) not being recognized after fresh install of X

Quote:
Originally Posted by EricB View Post
go to driverpacks.net and get the drivers

http://www.techist.com/forums/f9/how...rivers-182727/
I disabled the on board sound like you mentioned and was able to installer the SB audio drivers.

As for the video card, I installed the SP2 update and it came with the windows drivers you were talking about. They both seem be functioning properly now. Thanks for all the help.

I looked into the driver site and will dl those drivers and put them on discs just in case I may need them in the future. Again thanks for all the help.
__________________
GMEN316 is offline  
Old 12-05-2008, 09:04 PM   #6 (permalink)
Chillin Techie
 
Join Date: Nov 2004
Location: USA
Posts: 11,861
Default Re: PCI cards (Video card + Video Card) not being recognized after fresh install of X

Quote:
Originally Posted by GMEN316 View Post
I disabled the on board sound like you mentioned and was able to installer the SB audio drivers.

As for the video card, I installed the SP2 update and it came with the windows drivers you were talking about. They both seem be functioning properly now. Thanks for all the help.

I looked into the driver site and will dl those drivers and put them on discs just in case I may need them in the future. Again thanks for all the help.
no problem
__________________

__________________
The Ultimate Hard Drive Utility PowerMax 4.23. (It now has the ability to clean a Boot Sector virus on the quick erase option.)
The best browser Netscape 8
Have you accidently delete something? Look here (trial. the better one) and here(free)
EricB is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help With New Video Card Hunter434 System Upgrades 11 09-21-2009 05:30 PM
Upgrading Questions! yoshi1476 System Upgrades 14 09-30-2008 08:36 AM
WTB Older PC parts, 133mhz ram, IDE laptop HDD Compact Flash Cards PCI Video Card zerodayATK Buy/Sell/Trade and Hot Deals 4 02-22-2008 12:41 PM
damaged video card sb14blue Hardware Repairs and Troubleshooting 2 05-13-2007 02:13 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.