My Battlefield2 Wont work w/ Vista & ATi - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 02-22-2007, 09:45 AM   #1 (permalink)
Veteran Techist Member
 
Slam'n Systems's Avatar
 
Join Date: Mar 2003
Location: Albany, NY
Posts: 828
Default My Battlefield2 Wont work w/ Vista & ATi

I'm at a complete stand-still here and think it may be my ATi card not liking Vista. I installed Windows Vista Home Premium yesterday and re-installed my BF2, Patch & DX9c. I didn't update my video card drivers though and went into the game, played for a round, then next round my graphics turned to this:



Then I updated my drivers to the ATi Vista 32 Bit 7.2 Catalyst Drivers (The ones released yesterday) and I go into my game. I set my resolution and refresh rate to the same as my desktop, but everything starts going crazy, regardless what resolution I'm at .. like this:



So now I am completely lost as what to do from here. People in my squad told me they work fine with Vista & BF2, running it as Admin which I've been trying to do. So, anyone!?
__________________

__________________
3DMark FireStrike Ultra: 4,266
3DMark FireStrike: 12,043

  • Intel Core i7 920 Overclocked 3.2Ghz - Megahalem Cooler
  • eVGA E758-A1 X58 Intel LGA 1366 Motherboard
  • Corsair Vengeance 8GB DDR3 1600 RAM
  • MSI Armor OC 8GB GeForce GTX 1070
  • eVGA 650W G2 Modular Power Supply
  • Thermaltake Armor+ Full Tower Case
  • Samsung 850 EVO 500GB SSD
  • Corsair Force LE 250GB SSD
  • OCZ Vertex 30GB SSD
Slam'n Systems is offline  
Old 02-22-2007, 10:02 AM   #2 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default

Right click on the ece and there is a option. Run as Administrator. Choose that option and see if it helps any.
__________________

__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 02-22-2007, 10:52 AM   #3 (permalink)
Ultra Techie
 
Join Date: Dec 2006
Location: Liverpool, UK
Posts: 511
Default

I noticed you didn't say anything about graphics driver. Maybe try that.
__________________
Computer
HAF 932 -- ASUS P8Z68-V
Intel i5 @ 4.5Ghz -- CoolerMaster Hyper 212 Plus
8GB Corsair Vengeance Jet Black 1600MHz -- 2x XFX ATi Radeon HD 6970 2GB
Raze664 is offline  
Old 02-22-2007, 11:13 AM   #4 (permalink)
Veteran Techist Member
 
Slam'n Systems's Avatar
 
Join Date: Mar 2003
Location: Albany, NY
Posts: 828
Default

Between the 2 images I posted I explained that I updated to the 7.2 Catalyst Graphic Drivers for Vista.

Makaveli, I did try running as Administrator.

I think I figured out the problem. I uninstalled the 7.2 and went back and installed the older drivers; 7.1 and works fine now and has been working fine for over an hour O.o how weird is that huh? Seems 7.1 is better then 7.2 in my situation haha
__________________
3DMark FireStrike Ultra: 4,266
3DMark FireStrike: 12,043

  • Intel Core i7 920 Overclocked 3.2Ghz - Megahalem Cooler
  • eVGA E758-A1 X58 Intel LGA 1366 Motherboard
  • Corsair Vengeance 8GB DDR3 1600 RAM
  • MSI Armor OC 8GB GeForce GTX 1070
  • eVGA 650W G2 Modular Power Supply
  • Thermaltake Armor+ Full Tower Case
  • Samsung 850 EVO 500GB SSD
  • Corsair Force LE 250GB SSD
  • OCZ Vertex 30GB SSD
Slam'n Systems is offline  
Old 02-23-2007, 01:47 PM   #5 (permalink)
Ultra Techie
 
Join Date: Dec 2006
Location: Liverpool, UK
Posts: 511
Default

I had a problem with the latest nvidia drivers and source games, few months back.
__________________
Computer
HAF 932 -- ASUS P8Z68-V
Intel i5 @ 4.5Ghz -- CoolerMaster Hyper 212 Plus
8GB Corsair Vengeance Jet Black 1600MHz -- 2x XFX ATi Radeon HD 6970 2GB
Raze664 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.