Techist - Tech Forum

Techist - Tech Forum (http://www.techist.com/forums/)
-   Microsoft Windows and Software (http://www.techist.com/forums/f9/)
-   -   Maxtor HD recognition problem (http://www.techist.com/forums/f9/maxtor-hd-recognition-problem-93892/)

chainz 03-24-2006 09:43 AM

Maxtor HD recognition problem
 
Guys i have a maxtor external (you know one of those IDEs they put into a special case) and everything was fine its connected by a USB 2.0 cable and everything was fine. But then i wanted to reformat my computer so i did and i install all drivers etc and so i plug the HD in and turn it on and the little thing in the bottom right hand corner bar appears. But when i go to MY COMPUTER theres nothing there...I thought it was a problem with the computer so i took my thumb drive plugged it in but it did appear in MY COMPUTER.

So why doesnt my external appear in MY COMPUTER anymore like it used to?

please guys any help cuz ive got important stuff on it

Thanks!

MrCoffee 03-24-2006 01:11 PM

Are there drivers that need installing? just a stab in the dark.

KSoD 03-24-2006 05:43 PM

Have you tried to plug it in the USB port with it turned off. Than after you have it in the port turn it on?

I know a few times with my External i have had to turn it off and then back on for XP to recognize it.

chainz 03-25-2006 05:51 AM

hey guys i found out.

im using this recovery software and im just going to pull everything off it.

the only problem is that it only shows FOLDERS not files. what i mean is that on the HD i had saved files in folders all organized but some files i had saved just like that but i cant get them to show up....


All times are GMT -5. The time now is 03:59 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.