Installing video drivers - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 08-08-2005, 11:51 PM   #1 (permalink)
Junior Techie
 
Join Date: Jul 2005
Posts: 58
Send a message via AIM to CBerger
Default Installing video drivers

this question comes from my repeated freezing up in bf2, and someones solution i need to update my drivers. i have a sapphire x850xt pci express. now, it came with two discs, a catalyst 5.3 disc which i used when setting up my comp, and a redline tweak verserion 2.3 which i didnt use. on the ati site i saw that there is now a catalyst 5.7. now my question is whether i need the redline software, or the new catalyst. and if its the 5.7 catalyst, do i need to uninstall the old drivers or will running the exe auto update them to 5.7. thank you
__________________

__________________
Chaintech VNF4 :: AMD 3200+ winchester
Sapphire x850XT pci express :: 4x512 Kingston value ram pc-3200
250 GB Seagate barracuda :: Soundblaster audigy 2 zs
CoolerMaster Centurion 5 :: Antec Truepower 430 W
Sylvania 17\" flat :: Logitech MX500
Steelpad QcK :: Sennheiser PC150
CBerger is offline  
Old 08-08-2005, 11:55 PM   #2 (permalink)
True Techie
 
Join Date: Mar 2003
Posts: 200
Default

Uninstall the old ones first, and install the 5.7 drivers.
__________________

imation is offline  
Old 08-09-2005, 12:00 AM   #3 (permalink)
Junior Techie
 
Join Date: Jul 2005
Posts: 58
Send a message via AIM to CBerger
Default

do i uninstall by going into device manager hardware, then the display adapters? i have two listings though under display adapters. Radeon x850 series and Radeon x850 series - secondary. sorry i just dont want to mess anything up and want to be sure. thanks
__________________
Chaintech VNF4 :: AMD 3200+ winchester
Sapphire x850XT pci express :: 4x512 Kingston value ram pc-3200
250 GB Seagate barracuda :: Soundblaster audigy 2 zs
CoolerMaster Centurion 5 :: Antec Truepower 430 W
Sylvania 17\" flat :: Logitech MX500
Steelpad QcK :: Sennheiser PC150
CBerger is offline  
Old 08-09-2005, 08:34 AM   #4 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default

This page here...http://www2.ati.com/drivers/Catalyst...ase_notes.html should tell you all you need to know. It talks about issues (some with BF2) and gives you instructions on how to uninstall and reinstall you drivers.
__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 08-09-2005, 12:58 PM   #5 (permalink)
Junior Techie
 
Join Date: Jul 2005
Posts: 58
Send a message via AIM to CBerger
Default

ok well i followed the instructions on that page, and i downloaded catalyst 5.7 with catalyst control center. i uninstalled the drivers, installed the new ones, and it seems to work, but when i boot up, or when i try to open catalyst control center i get an error saying "CLI.exe - app error. the application failed to initialize properly" is that important or did i get what i needed? thanks again
__________________
Chaintech VNF4 :: AMD 3200+ winchester
Sapphire x850XT pci express :: 4x512 Kingston value ram pc-3200
250 GB Seagate barracuda :: Soundblaster audigy 2 zs
CoolerMaster Centurion 5 :: Antec Truepower 430 W
Sylvania 17\" flat :: Logitech MX500
Steelpad QcK :: Sennheiser PC150
CBerger is offline  
Old 08-09-2005, 02:41 PM   #6 (permalink)
Junior Techie
 
Join Date: Jul 2005
Posts: 42
Default

was this a new video card? If so, what kind did you have before this one?
__________________
Windows Vista Ultimate
Koolance Case
ASUS PCDL Motherboard
Dual Thermaltake Aquarius III
Dual Xeons 3.06 oc\'d to 3.38
2GB Kingston Hyper X
2 120gb HDD
geforce 5200 256
Dual Monitors
Dual DVD burners
pinkfloyd2005 is offline  
Old 08-09-2005, 02:58 PM   #7 (permalink)
Junior Techie
 
Join Date: Jul 2005
Posts: 58
Send a message via AIM to CBerger
Default

i had a radeon 9600, its a whole new computer
__________________
Chaintech VNF4 :: AMD 3200+ winchester
Sapphire x850XT pci express :: 4x512 Kingston value ram pc-3200
250 GB Seagate barracuda :: Soundblaster audigy 2 zs
CoolerMaster Centurion 5 :: Antec Truepower 430 W
Sylvania 17\" flat :: Logitech MX500
Steelpad QcK :: Sennheiser PC150
CBerger is offline  
Old 08-10-2005, 09:59 AM   #8 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default

It sounds like the Catalyst software didnt install correctly. It might have installed your drivers correctly you need to check you device manager to be sure.
__________________

__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.