IIS Personal Web Server setting ??? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 02-14-2006, 01:48 PM   #1 (permalink)
Junior Techie
 
Join Date: Jun 2005
Posts: 48
Send a message via Yahoo to j4mes_bond25
Default IIS Personal Web Server setting ???

I'm using Windows XP Professional on my laptop & I wonder if anyone could possibly point me in the right direction in setting my own Personal Web Server, for the purpose of uploading my personal website on it, which can be accessed from any other computer, just as any website.

Start >> Control Panel >> Add/Remove Programs >> Add/Remove Windows Components

Select Internet Information Services (IIS) & then Next

Then I did the following:

Start -> Settings -> Control Panel -> Administrative Tools -> Internet Information Services

From the "Web Sites" folder, I right-clicked & selected properties in the "Default Web Site" & the "Default Web Site Properties" box opens.

I assigned the "Website Description" name & then in the "Home Directory" tab, I wrote C:\Web_Root in the "Local Path", AFTER creating a "Web_Root" directory. Then, in the "Documents" tab, I checked "Enable default content page" & clicked "Add" & then typed in "index.html" page, which is a page, I designed & saved in C:\Web_Root.

I've done everything as per the intruction given on one of the website.

I finally typed in "http://localhost" but am getting the page saying:

"You are not authorized to view this page
You do not have permission to view this directory or page using the credentials you supplied. "

Wonder if anyone around could shed some light in making things work perfectly well.
__________________

__________________
Nope, I\'m NOT God, but I\'m British (which is the next best thing) ;)
j4mes_bond25 is offline  
Old 02-14-2006, 02:54 PM   #2 (permalink)
It's all just 1s and 0s
 
office politics's Avatar
 
Join Date: Jan 2004
Location: in the lab
Posts: 6,555
Send a message via MSN to office politics
Default

give the IUSR_COMPNAME user read access to the folder.
__________________

office politics is offline  
Old 02-14-2006, 03:47 PM   #3 (permalink)
Junior Techie
 
Join Date: Jun 2005
Posts: 48
Send a message via Yahoo to j4mes_bond25
Default csamuels !!!

Quote:
Originally posted by csamuels
give the IUSR_COMPNAME user read access to the folder.
Thanks for your help & I've now renamed it the way you mentioned, as you can see from the screen shot, however, yet getting the same screen as I was earlier.
Attached Images
File Type: jpg authentication screen.jpg (55.1 KB, 17 views)
__________________
Nope, I\'m NOT God, but I\'m British (which is the next best thing) ;)
j4mes_bond25 is offline  
Old 02-14-2006, 03:48 PM   #4 (permalink)
It's all just 1s and 0s
 
office politics's Avatar
 
Join Date: Jan 2004
Location: in the lab
Posts: 6,555
Send a message via MSN to office politics
Default

im sorry for not clarifying, you have to add the user to the web_root folder ACL. right click the folder in my computer and click properties. click security tab
office politics is offline  
Old 02-14-2006, 04:49 PM   #5 (permalink)
Junior Techie
 
Join Date: Jun 2005
Posts: 48
Send a message via Yahoo to j4mes_bond25
Default

Quote:
Originally posted by csamuels
im sorry for not clarifying, you have to add the user to the web_root folder ACL. right click the folder in my computer and click properties. click security tab
I'm terribly sorry, it seems that this "Web_Root" folder is already set to share on web, as you can see from the attached picture.
Attached Images
File Type: jpg web_root properties.jpg (38.9 KB, 15 views)
__________________
Nope, I\'m NOT God, but I\'m British (which is the next best thing) ;)
j4mes_bond25 is offline  
Old 02-14-2006, 07:19 PM   #6 (permalink)
It's all just 1s and 0s
 
office politics's Avatar
 
Join Date: Jan 2004
Location: in the lab
Posts: 6,555
Send a message via MSN to office politics
Default

youre looking for this

office politics is offline  
Old 02-14-2006, 07:32 PM   #7 (permalink)
Junior Techie
 
Join Date: Jun 2005
Posts: 48
Send a message via Yahoo to j4mes_bond25
Default csamuels !!!

Quote:
Originally posted by csamuels
youre looking for this

I managed to get it working now & the site can now be seen on http://192.168.0.101/, however, I wonder if YOU can see it yourself, since I think there could be the hiccup with INTERNAL/EXTERNAL IP & my External IP is 82.8.74.156 but sadly can't access my site by typing www.82.8.74.156.com OR 82.8.74.156.com OR http://82.8.74.156/, I'm afraid.

Any idea about dealing with this ???
__________________
Nope, I\'m NOT God, but I\'m British (which is the next best thing) ;)
j4mes_bond25 is offline  
Old 02-14-2006, 08:51 PM   #8 (permalink)
It's all just 1s and 0s
 
office politics's Avatar
 
Join Date: Jan 2004
Location: in the lab
Posts: 6,555
Send a message via MSN to office politics
Default

configure port forwarding on your router for port 80 to your machines internal ip
__________________

office politics is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.