Geforce 7600 GS driver? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 02-14-2007, 11:52 AM   #1 (permalink)
True Techie
 
dude112's Avatar
 
Join Date: Sep 2005
Posts: 236
Default Geforce 7600 GS driver?

I've looked on the nvidia site and i don't see the driver thats meant for this card. all i see is for the 8800 series and the go 7 series and plain geforce, but when chosing the go 7 series it says it's for GO 7800/7900. I don't think i have a go version either, just plain series 7. anyone know which drib\ver i'm suppose to get? I currently installed the one on the cd that was with this card (v.96.89)
__________________

dude112 is offline  
Old 02-14-2007, 12:02 PM   #2 (permalink)
PowerQuest / Opera
 
TheMajor's Avatar
 
Join Date: Jun 2004
Location: Netherlands
Posts: 10,177
Default

http://www.nvidia.com/content/licens...glish_whql.exe
__________________

__________________
TheMajorMMX - Intel P200 MMX @ 225Mhz - V-Tech (PcPartner) Baby-AT mb w/ Intel Triton TX chipset - Nvidia Riva TNT2 M64 w/ 16MB - 256MB M-Tec SDRAM - Still running.....
TheMajor is offline  
Old 02-14-2007, 12:28 PM   #3 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default

Your card is a GeForce so those are the drivers you want. As long as they are labeled for the GeForce series they are what you need. You wont find specific driver labeled just for your card since nVidia has a large selection of cards called GeForce and it would be way to big a list to have them all there.
__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 02-14-2007, 12:50 PM   #4 (permalink)
True Techie
 
dude112's Avatar
 
Join Date: Sep 2005
Posts: 236
Default

Ok thanks for the reply. I just thought there was suppose to be a compatibility list or something since radeon does do it by series. Also when i tried google i saw some people download the driver for the 8800.

edit: my bad. there was a pdf filewith the compatibility list. although it was somewhere in the middle.

edit2: now another problem has reared his head. When i play a game everything works fine but when i play a video everything tends to go extremely slow. basically freezes the computer. i've tried google and there was a solution where u go into troubleshooting and turn of hardware acceleration or something when watching a video and turning it on when playing games. this is a solution but not really an acceptable one. Anyone got an idea to fix this? I have updated the driver and no improvements.
__________________
Finished:
Case: Fractal Design R4 \ PSU: Corsair TX-650 V2\ Mobo: Asrock Z75 Pro 3
Processor: Intel i5 3570K Stock
RAM: Corsair Vengeance 8GB 1600C9 (2x 4GB) \ Videocard: Gigabyte 7950 Windforce 3
SSD: Samsung 830 \ HDD: Samsung SpinPoint F1 500GB \ DVD-RW: 1x LG
Speakers: Logitech (2.1)\ Monitor: Dell Ultrasharp U2312HM
Keyboard: MS Comfort Curve\ Mouse: Logitech MX 518
dude112 is offline  
Old 02-14-2007, 06:55 PM   #5 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default

Are you running XP or Vista?
__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 02-15-2007, 03:26 AM   #6 (permalink)
True Techie
 
dude112's Avatar
 
Join Date: Sep 2005
Posts: 236
Default

I'm running xp with sp2

edit: After a lot of searching and trying out stuff it seems that the drivers 9.xx are the problem. After I installed an 8.xx driver everything seems to work fine. This basically means I can't update my drivers anymore though. But if everything works just fine iI guess I don't really mind.

edit2: I'm going crazy. After downgrading my driver everything seemed fine but when i tried to watch a streaming video my computer crashed. New drivers won't work. Old ones won't work anyone? Oh yea, and when I've uninstalled all drivers I am able to watch video's and streaming vids.

My card is the XFX Geforce 7600 gs 256 mb AGP
System:
P4 3.2 ghz
1 gig mb ram
Asus P4S800 mobo
__________________

__________________
Finished:
Case: Fractal Design R4 \ PSU: Corsair TX-650 V2\ Mobo: Asrock Z75 Pro 3
Processor: Intel i5 3570K Stock
RAM: Corsair Vengeance 8GB 1600C9 (2x 4GB) \ Videocard: Gigabyte 7950 Windforce 3
SSD: Samsung 830 \ HDD: Samsung SpinPoint F1 500GB \ DVD-RW: 1x LG
Speakers: Logitech (2.1)\ Monitor: Dell Ultrasharp U2312HM
Keyboard: MS Comfort Curve\ Mouse: Logitech MX 518
dude112 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.