Frontpage Error! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 01-30-2005, 11:54 AM   #1 (permalink)
Newb Techie
 
Join Date: Oct 2004
Posts: 28
Default Frontpage Error!

When I open my frontpage application it gives me an error which states the following.......

"SERVER ERROR" CANNOT OPEN FILE "SERVICE.lck" FOR WRITING.

Can someone please throw some suggestions my way? I need to update a website and cannot as this error will not allow me to save updates.

Thank you much!

(V)uzaq(V)an
__________________

(V)UZAQ(V)AN is offline  
Old 01-30-2005, 12:06 PM   #2 (permalink)
Techie Beyond Description
 
Osiris's Avatar
 
Join Date: Jan 2005
Location: Kentucky
Posts: 36,817
Send a message via ICQ to Osiris Send a message via AIM to Osiris Send a message via MSN to Osiris Send a message via Yahoo to Osiris
Default

SYMPTOMS
When you attempt to open or list Webs using the FrontPage Server Extensions running on an IIS 3.0 or 4.0 computer, one of the following error messages may occur:
Server Error: Cannot open file "e:\InetPub\WWWRoot\_vti_pvt\service.lck" for writing.
Server Error: Cannot open file "e:\InetPub\WWWRoot\_vti_pvt\service.lck" for reading.
CAUSE
The error is caused by inappropriate permissions on the Service.lck file in the Web you are trying to open.
RESOLUTION
To resolve this problem, use one of the following methods:

Delete the Service.lck file. (It can become corrupted, especially by someone opening a Web then ending the network connection rather than exiting the FrontPage Explorer gracefully.)or

Reset the permissions for the Anonymous Account by doing the following:

For IIS 3.0

1. Click Start and point to Programs.
2. Point to Microsoft Internet Information Server.
3. Click Internet Service Manager.
4. Double-click the WWW Service
5. Uncheck the checkbox for Allow Anonymous.
6. Click Apply.
7. Open the Web in FrontPage.
8. When the Web is open re-check the checkbox for Allow Anonymous.
9. Click Apply
10. In the FrontPage client, on the Tools menu, click Permissions.
11. On the Users tab, select the radio button so only registered users have browse access.
12. Click Apply.
13. When the process has executed, select the radio button so everyone has browse access, and then click Apply.
You should now be able to open the Web with Anonymous Access turned on.

For IIS 4.0

1. Click Start and point to Programs.
2. Point to Microsoft Windows NT 4 Option Pack
3. Point to Microsoft Internet Information Server.
4. Click Internet Service Manager.
5. Right-click the virtual server that the Web is running on (for example the Default Web Site), and then click Properties.
6. On the Directory Security tab, click Edit in the Anonymous Access and Authentication Control section.
7. Uncheck the checkbox for Allow Anonymous.
8. Click OK twice.
9. Open the Web in FrontPage.
10. When the Web is open, re-check the checkbox for Allow Anonymous.
11. Click OK.
12. In the FrontPage client, on the Tools menu, click Permissions.
13. On the Users tab, select the radio button so only registered users have browse access.
14. Click Apply.
15. When the process has executed, select the radio button so everyone has browse access, and then click Apply.
__________________
Osiris is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.