dual boot problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 07-07-2004, 11:25 AM   #1 (permalink)
Junior Techie
 
Join Date: Feb 2004
Posts: 83
Default dual boot problem

ive got 98 and xp pro installed but only xp is starting up upon system boot

this is my boot.ini file

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Micro soft Windows XP Professional" /fastdetect

any idea how i modify this to incorperate 98 also

thanks
__________________

__________________
ASUS A7N8X-X mainboard
Athlon XP 3200+
1 GB Ram
120 GB HD (IDE)
250 GB HD (IDE)
128 MB Radeon 9800 PRO with custom H/S fan
8 x DVD Writer + DVD ROM
8 Meg ADSL (with ****ty ISP Bulldog)
Mystify Mamba mouse
And still ****ty fps in CS Source.
stumanoo is offline  
Old 07-07-2004, 11:41 AM   #2 (permalink)
Daf
Newb Techie
 
Join Date: Jul 2004
Posts: 36
Default

Hi,

First a couple of questions.

Which did you install first? Win98 then XP or vice versa?

Did you install onto separate partions or are you using separate drives?

Is the XP install NTFS?

Normally Win98 should be installed first - then XP.

Do a search on google using the keywords "dual boot xp win98" and check all the results - I saw several that may pertain to your situation but without knowing the details I can't be sure.

Hope this helps - post back if not. Or stand by and I'm sure you'll get some advice on this.

Daf
__________________

Daf is offline  
Old 07-07-2004, 12:22 PM   #3 (permalink)
Lord Techie
 
Join Date: May 2004
Location: Oklahoma
Posts: 5,280
Send a message via AIM to beedubaya
Default

Install 98 first with a FAT32 file system, then install XP on a seperate partition from withing Windows 98.
beedubaya is offline  
Old 07-07-2004, 07:28 PM   #4 (permalink)
Ultra Techie
 
Join Date: Mar 2004
Posts: 807
Default Re: dual boot problem

Quote:
Originally posted by stumanoo
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Micro soft Windows XP Professional" /fastdetect
Both beedubya and daf are right in saying Win98 should be loaded first whenever creating a dualboot. However, this doesn't seem to be a issue related to which OS was installed first.

Stumanoo, the reason why your dual-boot menu doesn't show the Win98 option is because the path for the Win98 isn't included in the boot.ini file. Look at the line just below [operating systems]
.... you should have anoterh line that reads something similar to:

multi(0)disk(x)rdisk(x)partition(x)\WINDOWS="Micro soft Windows"

Knowing which partition you installed Win98 is crucial here... you can manually create the line i typed above. where you see the 'X's.. is where it needs to be edited; however, I need to know where win98 is isntalled in order for me to help you further.
Lone Wolf is offline  
Old 07-12-2004, 02:06 PM   #5 (permalink)
Ultra Techie
 
Join Date: Mar 2004
Posts: 807
Default

Stumanoo,

In case you're still looking for an answer, try this:
At the very bottom of that boot.ini file, after the line that reads "Windows XP Professional" /fastdetect", on the next line type:

C:\="Microsoft Windows"

(provided that your Win98 is installed on the root of drive C:)

EDIT: forgot the quotes
Lone Wolf is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.