boot to c prompt - Win 98 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 08-04-2004, 11:18 AM   #1 (permalink)
Newb Techie
 
Join Date: Aug 2004
Posts: 4
Default boot to c prompt - Win 98

Hi,

I'm trying to fix a problem for a friend. His machine is a HP pavilion with Win98SE.

When booting up it gets as far as the initial "Windows 98" screen then goes immediately to a C: prompt.

Also - the text above the c: prompt looks just like when you boot to a boot disk.

[quote]This Driver is provided by Oak Technologies..." and appears to have load MSCDEX like a boot disc would.

There is only one drive/one partition - and the boot order (in BIOS) is set to boot to the had drive - so there is no confusion like I might be accidentally booting to another drive or disc.

I tried installing Win98 over itself - it installs but when you need to rebboot to continue setup - I get the C: prompt again. :|

I also can't find the boot.ini file anywhere...

It will, however, boot into safe mode.

Any ideas?

Thanks
Pete
__________________

newpcer is offline  
Old 08-04-2004, 12:29 PM   #2 (permalink)
Ultra Techie
 
Join Date: Mar 2004
Posts: 807
Default

You will NOT find the boot.ini file because that is created when you configure a dual-boot system or a multi-boot system. The message you see about the Oak Technologies is a just stating that it's loaded the generic drivers for your ATAPI devices (i.e. CD-ROM drivers).

It would be helpful to know what your friend was doing BEFORE this problem began. As I don't know if this is specifically s/w or h/w related. Before proceeding further, I would reallly like to know the answer to that.

Its probably something in the autoexe.bat or config.sys file that's causing this. If it boots into safe mode ok, you could try renaming the two files example: rename autoexec.bat to autoexec.bat.old. (You would first have to remove the "read-only" file attribute before renaming it).
__________________

Lone Wolf is offline  
Old 08-04-2004, 01:23 PM   #3 (permalink)
Newb Techie
 
Join Date: Aug 2004
Posts: 4
Default

Quote:
Originally posted by Lone Wolf

It would be helpful to know what your friend was doing BEFORE this problem began.
Me, too!!

Anyway - I renamed the autoexec.bat file and rebooted - it came up fine! - Thanks!!

What are the remifications of running without the autoexec? Can we just get on with using the computer now?

Thanks
Pete
newpcer is offline  
Old 08-04-2004, 01:31 PM   #4 (permalink)
Ultra Techie
 
Join Date: Mar 2004
Posts: 807
Default

The ramifications?....what ramifications?... your friend's PC boots up fine now... LOL

If you're asking if there's any harm running the PC w/ out those 2 files, the answer is No harm, no foul.

Those two files are DOS files that were need in dem "old" days with Win3.x OS. Win95 and above do not need those files although they remain as part of the overall system files as optional only.
Lone Wolf is offline  
Old 08-04-2004, 01:42 PM   #5 (permalink)
Newb Techie
 
Join Date: Aug 2004
Posts: 4
Default

Ah good - thanks so much for the help today!!

Pete
newpcer is offline  
Old 08-04-2004, 08:01 PM   #6 (permalink)
Wizard Techie
 
Join Date: Apr 2004
Posts: 3,247
Default

actually, I thought windows rebuilt those files... not sure, though... used to use that trick by renaming autoexec.bat to autoexec.123 and config.sys to config.123 then reboot, that or remove this from autoexec.bat if its there

Dos=single, call c:\window\command.com and c:\windows\win.com /wx

lol, someone just posted the EXACT same problem! hopefully he read my post before reinstalling 98SE over itself (as someone suggested... hmm??!) Just to let you know, for those reading this, I'd say a format or reinstallation shouldn't just be thrown around as the common fix as I've seen many just post a FFR often and if you do, I'd let the person know to wait a bit and see if anyone else has any ideas. This other person may have a FFR on his hand if he did as suggested and installed 98 on top of itself for just what LOOKS to be a simple DOS loop.
__________________

__________________
If you argue with an idiot he will drag you down to his level and beat you with experience.

I am not a fast writer.
I am not a slow writer.
I am a half-fast writer.

-Robert Asprin
killians45 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.