avi file causing my explorer to crash!!! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 06-18-2005, 10:18 PM   #1 (permalink)
True Techie
 
Join Date: Feb 2005
Posts: 235
Exclamation avi file causing my explorer to crash!!!

My System:


you know when your explorer crashes, your task bar disappears for a while.. and then it is reloaded after a few seconds.. but with some of your system tray icons missing already? yah.. that kinda crash...

well, it happens every single time i :

1) open the AVI file from explorer
2) select the AVI file by just 1 click or scrolling down to it.. soon as it is highlighted, boom, crash (VIEW TYPE = LIST)
3) enter the directory where the AVI file is (VIEW TYPE = thumbnails)
4) enter the directory where the AVI file is (VIEW TYPE = FILM STRIP)

the only trigger i can think of here is when windows attempts to display a preview of the avi files... coz if in LIST VIEW and i don't select it.. everything is fine. but as soon as i select it, or set the folder view to thumbnails.. as soon as it gets drawn, boom.. explorer crashes..

This happens on some specific avi files only.. right now i got like 4 of these avi files that causes my explorer to crash.. but these files are FINE.. if i select them /open them from windows media player itself, no problems..

any ideas?
__________________

clever_j is offline  
Old 06-18-2005, 10:41 PM   #2 (permalink)
Wizard Techie
 
Join Date: Jun 2005
Posts: 3,339
Default

Very interesting how you got my avatar in your banner but anyways it is always possible the file is corrupted.
__________________

__________________
<form action=\"http://www.srsyo.org/tfsearch.php\" method=\"get\">
<input type=\"text\" name=\"search\"> <input type=\"submit\" name=\"submit\" value=\"Search TF before you post!\"></form>
Vista Discussion | 64 Bit Discussion |Microsoft Homepage | Yo Linux | Paul Thurrott | Fire Fox | Thunder Bird | Image Shack | Photo Bucket | Put File | Anti-Spyware | MS Anti-Spyware | Trillian | Anti-Virus | On Line Virus Scan
Tyler1989 is offline  
Old 06-18-2005, 11:32 PM   #3 (permalink)
True Techie
 
Join Date: Feb 2005
Posts: 235
Default

Quote:
Very interesting how you got my avatar in your banner
lol .. umm.. i've had this firefox eating IE gif for months already.. shared to me from another forum.. why? were you the one who made this?

Quote:
nyways it is always possible the file is corrupted.
I can verify that it isnt corrupted.. i did filechecks, also played the whole file without a problem.. and finally, i tried it on another computer.. and it didnt cause any problems.. same XP with sp2 setup..
clever_j is offline  
Old 06-19-2005, 12:04 AM   #4 (permalink)
Wizard Techie
 
Join Date: Jun 2005
Posts: 3,339
Default

Are you forgetting the basics like an AVI codec media player doesn't support this by defualt. Do you hav DivX6.0?
__________________
<form action=\"http://www.srsyo.org/tfsearch.php\" method=\"get\">
<input type=\"text\" name=\"search\"> <input type=\"submit\" name=\"submit\" value=\"Search TF before you post!\"></form>
Vista Discussion | 64 Bit Discussion |Microsoft Homepage | Yo Linux | Paul Thurrott | Fire Fox | Thunder Bird | Image Shack | Photo Bucket | Put File | Anti-Spyware | MS Anti-Spyware | Trillian | Anti-Virus | On Line Virus Scan
Tyler1989 is offline  
Old 06-19-2005, 12:19 AM   #5 (permalink)
True Techie
 
Join Date: Feb 2005
Posts: 235
Default

Quote:
Are you forgetting the basics like an AVI codec media player doesn't support this by defualt. Do you hav DivX6.0?
first of all, media player DOES PLAY THE FILES.. there are no problems there.. my problem is with the EXPLORER. It crashes...

and yes, I have all the latest codecs.. i keep myself updated with the K-Lite codec pack... and well, i can confirm also that the files aren't DiVX..
clever_j is offline  
Old 06-19-2005, 12:23 AM   #6 (permalink)
Wizard Techie
 
Join Date: Jun 2005
Posts: 3,339
Default

Well there is your problem you use Kazaa it's the source of all evil uninstall it ASAP and try limeware or bearshare. Yes but if media player has an error reading it it could freeze up explorer. Stick with my recommendation

1.) Uninstall Kazaa and any Kazaa related software
2.) Install Limeware or Bearshare, these are like Kazaa but better
3.) Install DivX this is a great download that comes with a great codec
4.) Since you are a Kazaa user download and scan for viruses and spyware
__________________
<form action=\"http://www.srsyo.org/tfsearch.php\" method=\"get\">
<input type=\"text\" name=\"search\"> <input type=\"submit\" name=\"submit\" value=\"Search TF before you post!\"></form>
Vista Discussion | 64 Bit Discussion |Microsoft Homepage | Yo Linux | Paul Thurrott | Fire Fox | Thunder Bird | Image Shack | Photo Bucket | Put File | Anti-Spyware | MS Anti-Spyware | Trillian | Anti-Virus | On Line Virus Scan
Tyler1989 is offline  
Old 06-19-2005, 12:31 AM   #7 (permalink)
True Techie
 
Join Date: Feb 2005
Posts: 235
Default

lolz.. who said i was on kazaa? I hate that piece of crap! hehhe

yep..i've been using limewirePro for months already.. no kazaa here...

maybe you thought K-Lite was kazaa (since i dont see any mention of anything else that would resemble to kazaa).. The k-lite i installed isnt KAzaa Lite. There are different codec packs out there, and the most recommended one is the K-Lite codec pack.. it's a complete Audio and Video codec pack.. no way is it related to kazaa.
clever_j is offline  
Old 06-19-2005, 08:15 AM   #8 (permalink)
Newb Techie
 
Join Date: Apr 2005
Posts: 14
Default

It could be a corrupted avi. I had a 700MB one which would immediately lock the file once opening the folder it was located in, use 50% system resources and I had to use killbox to get rid of it with the close explorer shell while deleting option enabled. Otherwise I use the slightly lighter divx total pack 2.2 with media player classic. There's some reg patch which disables xp from accessing avi information within the file which might help cure your problems.
Tasslehoff is offline  
Old 06-19-2005, 11:27 AM   #9 (permalink)
True Techie
 
Join Date: Feb 2005
Posts: 235
Default

@tassleholf

i dont think it's corrupted avi file mate.. i tried it on another computer and it's working fine.. didnt crash the explorer on my brother's pC..

Quote:
There's some reg patch which disables xp from accessing avi information within the file which might help cure your problems.
hmm.. this could be my problem.. what/where is it?
clever_j is offline  
Old 06-20-2005, 02:12 AM   #10 (permalink)
Newb Techie
 
Join Date: Apr 2005
Posts: 14
Default

Ah geez when I click the thumbnail view my 300+ file folder also crashes explorer. I used the [last resort method] below which appears to be a temp fix until i figure out why vsfilter.dll is s***ing itself on the thumbnail view of this folder.

I think it might be the following, go to the following registry key:
[HKEY_CLASSES_ROOT\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}]
try putting a minus in front of the {87d...} or
[HKEY_CLASSES_ROOT\CLSID\-{87D62D94-71B3-4b9a-9489-5FE6850DC73E}]
be sure to change it back it it doesn't work, fairly sure this doesn't need a reboot after trying on my machine.
Or if you think your avi key thingie might be totally frelled, export your original key to a safe location, delete the one in the registry, create a txt file and paste the following in:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}]
@="Avi Properties Handler"

[HKEY_CLASSES_ROOT\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00 ,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00 ,32,00,5c,00,73,00,68,00,\
6d,00,65,00,64,00,69,00,61,00,2e,00,64,00,6c,00,6c ,00,00,00
"ThreadingModel"="Both"

Rename the txt extension to reg and double click it and let us know if anything happens. This might need a reboot?

[last resort method]
as a last resort type the following at the start run prompt

regsvr32 /u shmedia.dll
try running the thumbnail view or highlight the file and see what happens.

regsvr32 shmedia.dll to undo.
__________________

Tasslehoff is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.