Assigning Drive Letters!!!!!!!! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 11-28-2004, 06:33 PM   #1 (permalink)
Newb Techie
 
Join Date: Oct 2004
Posts: 28
Default Assigning Drive Letters!!!!!!!!

Ok, I deleted win 98 and put in 2000.

The problem I had was that I accidently partitioned the main drive (which should be C into 2 partitions.

1 partition is 2 gig the other 10 gig. the 2 gig is showing as the C: drive and the 10 is showing as the G:. I also have another HD which is D: but not in question at this point.

The G: drive is the drive containing the OS and the C: has nothing. I tried changing the drive letters from C to G and G to C but it tells me that it can not change a boot volume. The G: drive is listed as the Logical.

Can someone help me out here or should I just leave the G as the primary???

Thanks!

(V)uzaq(V)an
__________________

(V)UZAQ(V)AN is offline  
Old 11-28-2004, 06:48 PM   #2 (permalink)
PowerQuest / Opera
 
TheMajor's Avatar
 
Join Date: Jun 2004
Location: Netherlands
Posts: 10,177
Default

Quote:
The G: drive is listed as the Logical.

Can someone help me out here or should I just leave the G as the primary???
Is G: logical or primary?

This can be dangerous. U can delete the C, move G to the beginning of the drive or merge C and G... very dangerous though.. it can screw your system and make it unable to boot. I would suggest a re-install (re-partition first)

Does windows boot?
__________________

__________________
TheMajorMMX - Intel P200 MMX @ 225Mhz - V-Tech (PcPartner) Baby-AT mb w/ Intel Triton TX chipset - Nvidia Riva TNT2 M64 w/ 16MB - 256MB M-Tec SDRAM - Still running.....
TheMajor is offline  
Old 11-28-2004, 07:03 PM   #3 (permalink)
Newb Techie
 
Join Date: Oct 2004
Posts: 28
Default

boots up fine!
(V)UZAQ(V)AN is offline  
Old 11-28-2004, 07:05 PM   #4 (permalink)
Chillin Techie
 
Join Date: Nov 2004
Location: USA
Posts: 11,861
Default

the major is right

partition magic might be able to fix it. i think you need to reformat
EricB is offline  
Old 11-28-2004, 10:04 PM   #5 (permalink)
Newb Techie
 
Join Date: Oct 2004
Posts: 28
Default

Ok, I reformatted the drive and ran into another issue..lol (figures)When I boot up, right before the Windows 2000 start up screen it says "Please select an OS to start and I have a listing of (2) Window 2000 OS's. Regardless of which one I hit or just wait the 30 seconds it boots up without a hitch.
My question is....

1) Why do I have it showing (2) Windows 2000 OS's

2) And why does this screen pop up at all??????

Any suggestions to eleviate this problem will be appreciated!

Thanks!
(V)UZAQ(V)AN is offline  
Old 11-28-2004, 10:07 PM   #6 (permalink)
Lord Techie
 
Join Date: May 2004
Location: Oklahoma
Posts: 5,280
Send a message via AIM to beedubaya
Default

Edit your boot.ini file and remove the Windows 2000 copy you don't want.
beedubaya is offline  
Old 11-28-2004, 10:07 PM   #7 (permalink)
PowerQuest / Opera
 
TheMajor's Avatar
 
Join Date: Jun 2004
Location: Netherlands
Posts: 10,177
Default

Did you re-install 2K?

something with you boot.ini file. post your boot.ini file.
start/run type "boot.ini"

not sure this works in 2k
__________________
TheMajorMMX - Intel P200 MMX @ 225Mhz - V-Tech (PcPartner) Baby-AT mb w/ Intel Triton TX chipset - Nvidia Riva TNT2 M64 w/ 16MB - 256MB M-Tec SDRAM - Still running.....
TheMajor is offline  
Old 11-29-2004, 07:47 AM   #8 (permalink)
Newb Techie
 
Join Date: Oct 2004
Posts: 28
Default

Will give it a shot after work today!

I will keep you posted!

Thanks.

(V)uzaq(V)an
(V)UZAQ(V)AN is offline  
Old 11-29-2004, 08:05 PM   #9 (permalink)
Wizard Techie
 
Join Date: Apr 2004
Posts: 3,247
Default

Oh man, you didn't have to format! Well, for future reference its just a little registry editing that needs to be done. Warning, though, any programs installed AFTER the system disk became the G: drive may need reinstalling because it will be looking to the G: drive and not the C:. Anyhow, to change the system disk, do the following...

1. Run regedit and goto the following key:
HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

2. Change your \DosDevices\C: listed in there to something like \DosDevices\X: (or anyother non existant drive).

3. Now change the \DosDevices\G: to say \DosDevices\C: (reason we changed the original to X: or whatnot is so there was no duplicate drive letter, get it ...)

4. Finally all you have to do is change the \DosDevices\X: (or whatever you renamed the original to) to be \DosDevices\G: or whatever drive letter you want it to be and that is free to use.

Thats it, just exit the registry and restart (it wont show correctly until a restart).

Also, DO YOURSELF A FAVOR!!! Backup you registry before doing this and DONT touch anything else listed else you may have worse problems to deal with.
__________________

__________________
If you argue with an idiot he will drag you down to his level and beat you with experience.

I am not a fast writer.
I am not a slow writer.
I am a half-fast writer.

-Robert Asprin
killians45 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.