argus 1620 QC driver problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 11-10-2005, 11:10 PM   #1 (permalink)
Banned
 
Join Date: Apr 2005
Location: n/a
Posts: 2,956
Exclamation argus 1620 QC driver problem

I'm having a small problem with my digital camera, I bought this argus digital camera quick clix 1620 from target for 14.99 I apparently lost the miniture disc and find the blasted thing anywhere.......

everytime I download the driver from argus website and install it I'll take the camera and plug it into my USB hub and will bing! ding ! which meens that windows found it or so it thought..... so it searches for the drivers but can't find nothing... so each time I plug in my camera it will go beep!, beep!, beep!, which means I am unrecognize under windows xp and can't operate perform corretly......!

I have tried these steps will make most of the devices work after the first try download,intsall driver, reboot, plug it in after windows xp calms down from loading the bare minimum of programs that show up and theres my device waiting to be used

can someone please tell me how to fix this driver problem with XP SP2 pro or basic windows xp pro SP1 so that can get my camera to work again please ?
__________________

-RockMan- is offline  
Old 11-10-2005, 11:11 PM   #2 (permalink)
Techie Beyond Description
 
Osiris's Avatar
 
Join Date: Jan 2005
Location: Kentucky
Posts: 36,817
Send a message via ICQ to Osiris Send a message via AIM to Osiris Send a message via MSN to Osiris Send a message via Yahoo to Osiris
Default

did you go to device manager, update the drive tab, the manually select the driver location and then let windows install it?
__________________

__________________
Osiris is offline  
Old 11-10-2005, 11:32 PM   #3 (permalink)
Chillin Techie
 
Join Date: Nov 2004
Location: USA
Posts: 11,861
Default

get a camera other than a cheap argus
__________________
The Ultimate Hard Drive Utility PowerMax 4.23. (It now has the ability to clean a Boot Sector virus on the quick erase option.)
The best browser Netscape 8
Have you accidently delete something? Look here (trial. the better one) and here(free)
EricB is offline  
Old 11-11-2005, 12:34 AM   #4 (permalink)
Banned
 
Join Date: Apr 2005
Location: n/a
Posts: 2,956
Default

Yes WM I have done what you said and nothing shows up, however though know why windows can't find it, because when I ran the setup program and installed the driver which I ~thought~ it was doing it did not make the program inside c windows program and put the driver inside of it so thats why windows does not detect anything is it possible that somebody may have a driver out on the web for me to use or try to get a repalcement disc ? I really do need tp acceses this camera to get some files off off of it.
-RockMan- is offline  
Old 11-11-2005, 01:54 AM   #5 (permalink)
Chillin Techie
 
Join Date: Nov 2004
Location: USA
Posts: 11,861
Default

I had the same problem a few years ago. Argus has too many issues. I sot a sony digital camera (I paid 150 bucks for that argus too)
__________________
The Ultimate Hard Drive Utility PowerMax 4.23. (It now has the ability to clean a Boot Sector virus on the quick erase option.)
The best browser Netscape 8
Have you accidently delete something? Look here (trial. the better one) and here(free)
EricB is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.