Sony Vaio Pcg-7f1l Laptop won't start - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Laptops and Notebooks
Closed Thread
Thread Tools Display Modes
Old 12-11-2008, 12:41 PM   #1 (permalink)
Newb Techie
Join Date: Dec 2008
Posts: 3
Default Sony Vaio Pcg-7f1l Laptop won't start

Please help! my laptop won't start. No light, no fan running, no noise except for a little tiny ticking noise in the bottom of the laptop. I've changed the power chord and still the same. Please help!

pcg7f1l is offline  
Old 12-11-2008, 01:33 PM   #2 (permalink)
Wizard Techie
Lexluethar's Avatar
Join Date: Jul 2008
Posts: 4,708
Send a message via AIM to Lexluethar
Default Re: laptop wont start

Clicking would be coming from the hard drive, which would indicate IMO a bad hard drive.

If you've already replaced the power cord (save yourself money next time and test the power cord with a Multimeter prior to assuming the power cord is bad) and you aren't getting power to the system and it isn't booting up AT ALL then you have a bad system board or connector on the system board.

So essentially you have two issues here, the clicking is coming from the hard drive, and if it clicks at startup then it is starting up and trying to read the hard drive. So you could replace the hard drive (probably 40 - 60 bucks) and see if that fixes the issue.

The other issue is the power. If you truely aren't seeing lights and it isn't doing ANYTHING at startup (which you already said it was b/c of the noise, but said it wasn't because of no lights...) it is a power issue which you would need to possibly replace the system board.

-Vista SME
Lexluethar is offline  
Old 12-11-2008, 02:43 PM   #3 (permalink)
Newb Techie
Join Date: Dec 2008
Posts: 3
Default Re: Sony Vaio Pcg-7f1l Laptop won't start

Lex, nothing happens when i press the power button, no lights, no fan noise, nothing at all. When I plug the power cord in to the laptop then a ticking noise comes on from the bottom of the laptop. Keep in mind the power is still not on. I removed the power cord and no more ticking noise.
pcg7f1l is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony Vaio PCG-7F1L laptop won't start jlambe5 Hardware Repairs and Troubleshooting 0 04-30-2008 08:45 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:47 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.