PLEASE HELP - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Laptops and Notebooks
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 08-23-2015, 10:06 PM   #1 (permalink)
Newb Techie
 
Join Date: Aug 2015
Location: nowhere
Posts: 18
Exclamation PLEASE HELP

Hey I have an Alienware m18 laptop, and for some reason today 3 times, the screen has gone completely black, but the pc still runs, it's just the screen going black, i dont know why its doing this, i called alienware they couldn't give me any suggestions they want like 80 to 100 dollars to go in to the computer and run diagnostics, i dont have that kind of money on hand, what can i do why is it doing this any suggestions?
__________________

nobodyimporant is offline   Reply With Quote
Old 08-23-2015, 10:11 PM   #2 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,513
Default Re: PLEASE HELP

Did you change anything recently? Is your system still under warranty?

Did you upgrade to Windows 10 by chance? I know there's been reports of WIndows 10 & the current nVidia driers killing LCD displays in Alienware systems with certain GPU's - seems to be an issue with something corrupting the panels' EDID / firmware.
__________________

__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is online now   Reply With Quote
Old 08-23-2015, 10:12 PM   #3 (permalink)
Banned
 
Join Date: Jul 2015
Location: Enid Oklahoma
Posts: 331
Default Re: PLEASE HELP

Hi A quick question! Are you running on the battery or are you running on the AC adapter??
Oops sorry carnage! We seem to reply at the same time a lot!!
donetao is offline   Reply With Quote
Old 08-24-2015, 03:39 AM   #4 (permalink)
Newb Techie
 
Join Date: Aug 2015
Location: nowhere
Posts: 18
Default Re: PLEASE HELP

i have my laptop plugged in, sometimes i run it on battery doesn't matter it still does it, it's been doing this all day to me, i still have windows 7 i won't update to windows 10, all my drivers are up to date, i'm thinking alienware is just a rip off and i should sue them and get my money back
nobodyimporant is offline   Reply With Quote
Old 08-24-2015, 07:22 AM   #5 (permalink)
Lord Techie
 
Join Date: Feb 2005
Location: asdf
Posts: 8,887
Default Re: PLEASE HELP

Inverter failing for the LCD most likely... Will require a new screen in most cases. Fairly common to have them fail.
c0rr0sive is offline   Reply With Quote
Old 08-24-2015, 07:31 AM   #6 (permalink)
Monster Techie
 
rulezero's Avatar
 
Join Date: Jan 2015
Location: Earth
Posts: 1,685
Default Re: PLEASE HELP

I'd try the drivers first, then reseat the screen (take it out and plug it it back in) if its still failing then buy a replacement, will cost you around $150 prob but cheaper than paying $100 for a diagnostic then another $150 for the screen
__________________
Don't like what I say, ban me!
rulezero is offline   Reply With Quote
Old 08-24-2015, 11:48 AM   #7 (permalink)
Night Ninja
 
MidnightShadow's Avatar
 
Join Date: Jun 2015
Location: USA
Posts: 776
Default Re: PLEASE HELP

When the screen blacks out, how are you turning it off or are you just leaving it running and the screen eventually comes back?

If the consensus is that it's the screen, you need to connect an external monitor to it to verify. If the screen blacks out but not the monitor, bing. If they both black out, it's something different such as drivers or software.
__________________
MidnightShadow is offline   Reply With Quote
Old 08-26-2015, 05:34 PM   #8 (permalink)
Newb Techie
 
Join Date: Aug 2015
Location: nowhere
Posts: 18
Default Re: PLEASE HELP

hey i cleaned it out and it isnt doing it anymore and plus i did a scan there was a trojan i got rid of it so eiher it was the trojan or overheating but it's not doing it anymore so issue resolved no problem the problem is resolved thanks everyone
nobodyimporant is offline   Reply With Quote
Old 08-27-2015, 05:51 AM   #9 (permalink)
Super Techie
 
cb600fshornet's Avatar
 
Join Date: Jun 2015
Location: England, Birmingham
Posts: 361
Default Re: PLEASE HELP

Glad to hear that it's working now!
__________________

cb600fshornet is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please Please PLEASE help me SubliminalX7 General Security Topics 10 01-22-2015 07:09 PM
Please Help! Please Help! Please Help! thebeliever Viruses, Spyware and Malware 7 12-27-2010 11:00 PM
Asus P5ld2-vm-cr-si... PLEASE HELP PLEASE TAKE A LOOK PLEASE little_emmynem Monitors, Printers and Peripherals 1 01-10-2008 02:17 PM
help help help, please please,rescue me francy Overclocking and Modding 2 06-21-2006 03:20 PM
please, please, please help me in this md Microsoft Windows and Software 1 08-12-2005 03:55 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.