Dell Inspiron 4150/Latitude C640 Battery won't charge - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Laptops and Notebooks
Closed Thread
Thread Tools Display Modes
Old 10-21-2007, 02:04 PM   #1 (permalink)
Newb Techie
Join Date: Jan 2004
Posts: 34
Default Dell Inspiron 4150/Latitude C640 Battery won't charge

I have two batteries, both of which will charge in my inspiron 4000, but not in my inspiron 4150(in which i recently replaced the motherboard with one from a c640, they're identical). If i charge a battery in the 4000, I can use it in the 4150, and it will report the correct charge amount and everything, but when I plug in the AC adapter, it says "charging" but never actually charges the battery at all. The lights on the side of the computer for "on","battery",and "charge" don't function, i'm not sure if these ever functioned after my motherboard swap.

About a week ago the 4150 worked fine, i had bought a new battery off of ebay and when i put it in the 4150, it would charge but wouldn't read the percentage, it would flicker on and off between 'no battery' and 'charging'. I sent the battery back and he replaced it with one that works fine, but now my laptop isn't working.

HELP! i'm afraid that bad battery short circuit my charging system.


edvosder is offline  
Old 10-24-2007, 05:45 PM   #2 (permalink)
Ultra Techie
objecterror's Avatar
Join Date: Jan 2006
Location: United States
Posts: 724
Default Re: Dell Inspiron 4150/Latitude C640 Battery won't charge

Well, you could check your powersupply, alot of the time when your battery isn't charging it's the problem of the powersupply. Check your line to see if there is a short in it or try another powersupply. If it's not the line/cord then you should check to make sure your laptop is getting in enough power to power in the first place.

It works like some replacement powersupplies for cameras, they do the job at 'powering' the camera but it won't give you enough juice to power it and then charge the battery, i'd assume it's either the line or the unit itself thats having some connection issues with actually pulling power and retaining it.
i5 2400 @ 3.10Ghz | 16GB RAM | 500GB + 1TB | GTX 750Ti
objecterror is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade Dell Inspiron 600m Memory/HDD Laptop jto18 Laptops and Notebooks 1 09-11-2007 10:16 PM
Dell Inspiron 9300 upgrade Jlagreca Laptops and Notebooks 4 09-09-2007 05:45 PM
Dell Inspiron Motherboard/Memory Problem Jaco42 Hardware Repairs and Troubleshooting 0 07-10-2007 01:12 AM
Dell Inspiron E1705 lluwas New Systems | Building and Buying 1 06-05-2007 09:00 AM
need help dell inspiron 8500 cpu speed Calgary Overclocking and Modding 3 04-15-2007 10:16 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:40 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.