d-link dwl-650+ pcmcica card not working - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Laptops and Notebooks
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 02-06-2009, 10:59 AM   #1 (permalink)
Newb Techie
 
Join Date: Feb 2009
Posts: 10
Default d-link dwl-650+ pcmcica card not working

Hello, I've recently been trying to get my d-link dwl-650+ cardbus adaptor to work (again) with my slightly old toshiba P4 satellite laptop.

I've followed the installation steps a number of times (install software/drivers, then turn off, install card, and reboot) but each time I get errors.

First off, the d-link wifi software loads, but has an X over the reception meter and says "no dlink card found" then quits automatically after a few seconds.

In device manager, it has a yellow "!" and it gives one of 2 errors.

Code 12, which means that it can't find enough resources to load device (even though there should be enough resources, and i've shut off every other resource to try and diagnose the problem).

code 35, which says that the host / driver files may be corrupt. While this is possible, I doubt that that's actually the case, as I've gotten the files in different versions from multiple sources, so I'd doubt they were all corrupt (though, of course, still possible).


I consider myself relatively computer savvy, but I'm just at a complete loss for this, and even "the google" couldn't help me out, so I figured, why not go to the place where my computer prowess is that of a cockroach =)

Thanks a bunch for any advice, everyone!

Jon
__________________

studiorion is offline  
Old 02-06-2009, 11:03 AM   #2 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: d-link dwl-650+ pcmcica card not working

have you downloaded and tried the latest drivers from the dlink website?
D-Link TechSupport
__________________

__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 02-06-2009, 11:04 AM   #3 (permalink)
Newb Techie
 
Join Date: Feb 2009
Posts: 10
Default Re: d-link dwl-650+ pcmcica card not working

Quote:
Originally Posted by hefemeister View Post
have you downloaded and tried the latest drivers from the dlink website?
D-Link TechSupport - Choose Your Country

Aye, I've tried the latest drivers, and any other versions I could find, to try to debug where the issue is
studiorion is offline  
Old 02-06-2009, 11:06 AM   #4 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: d-link dwl-650+ pcmcica card not working

did you look at this?

D-Link TechSupport problems installing on laptop
__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 02-06-2009, 11:08 AM   #5 (permalink)
Newb Techie
 
Join Date: Feb 2009
Posts: 10
Default Re: d-link dwl-650+ pcmcica card not working

Yup, it helped determine if it's a 16 or 32 bit cardbus adaptor
studiorion is offline  
Old 02-06-2009, 11:14 AM   #6 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: d-link dwl-650+ pcmcica card not working

What laptop do you have? If it was a dell or toshiba I would assume you did the bios update suggested. You disabled your onboard lan for the install? Turned off any firewall running? Logged on as an admin?

You really seem to know what you are doing. I am just hoping to find some method you have not tried yet so sorry if I keep posting steps you have already taken.
__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 02-06-2009, 11:15 AM   #7 (permalink)
Newb Techie
 
Join Date: Feb 2009
Posts: 10
Default Re: d-link dwl-650+ pcmcica card not working

Quote:
Originally Posted by hefemeister View Post
What laptop do you have? If it was a dell or toshiba I would assume you did the bios update suggested. You disabled your onboard lan for the install? Turned off any firewall running? Logged on as an admin?

You really seem to know what you are doing. I am just hoping to find some method you have not tried yet so sorry if I keep posting steps you have already taken.
Oh don't worry, I won't be offended, because, it's pretty likely that I just missed a step somewhere hehe, now I"m gonna try to update the bios and see if that helps
studiorion is offline  
Old 02-06-2009, 11:18 AM   #8 (permalink)
Master Techie
 
NightSurge's Avatar
 
Join Date: Feb 2008
Location: Fort Wayne, IN
Posts: 2,217
Send a message via AIM to NightSurge
Default

What operating system are you using? As long as it isn't as old as Windows 95, and as long as it isn't Vista the drivers should not be at fault.

Also, the only other limitation I see is that it requires 32Mb of RAM, but again I am sure you have plenty of that as well.

System Requirements:
A laptop computer with an available 32-bit Cardbus PC Card slot
Windows XP, Windows 2000, Windows Me, or Windows 98
Cardbus Controller, properly installed and working
At least 32 MB of memory and a 300 MHz processor
An 802.11b Access Point (e.g., DWL-900AP+ for Infrastructure
Mode) or another 802.11b wireless adapter (e.g., DWL-520 for Ad-
Hoc mode.)

If you meet all that, then I would say I'm at a loss. Could try a fresh install, but there's no guarantee's there either.
__________________

If I was helpful, please click the icon on the left hand side of this message that looks like a check mark Thanks!

NightSurge is offline  
Old 02-06-2009, 11:20 AM   #9 (permalink)
Newb Techie
 
Join Date: Feb 2009
Posts: 10
Default Re: d-link dwl-650+ pcmcica card not working

Using winxp SP2, 786 megs of ram
studiorion is offline  
Old 02-06-2009, 11:21 AM   #10 (permalink)
Master Techie
 
NightSurge's Avatar
 
Join Date: Feb 2008
Location: Fort Wayne, IN
Posts: 2,217
Send a message via AIM to NightSurge
Default Re: d-link dwl-650+ pcmcica card not working

And your cardbus controller is confirmed working/installed correctly? If so, then again I am at a loss on this one. Perhaps the Bios update will help.
__________________

__________________

If I was helpful, please click the icon on the left hand side of this message that looks like a check mark Thanks!

NightSurge is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet connection sharing behind a router KSoD Computer Networking and Internet Hardware 8 03-01-2016 11:32 AM
What To Look For When Buying Computer Components Luke Monitors, Printers and Peripherals 25 01-07-2009 09:09 PM
PCI cards (Video card + Video Card) not being recognized after fresh install of XP GMEN316 Microsoft Windows and Software 5 12-05-2008 10:04 PM
Graphics Card and Power Supply ratzlaff System Upgrades 6 04-29-2008 12:55 PM
Lower Video Card noise by reducing the fan speed Osiris Monitors, Printers and Peripherals 0 01-01-2008 12:53 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.