Charging problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Laptops and Notebooks
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 09-18-2008, 12:51 PM   #1 (permalink)
Super Techie
 
Join Date: Jun 2004
Posts: 402
Unhappy Charging problem

Hello people I have a problem with my laptop here.
It stopped charging a few weeks ago so I got a lend of a mates universal laptop charger to try and see if it was my charger that was playing up but still couldnít get it going. I thought then that maybe the battery was the problem so I bought a replacement, which started the laptop up and all grand Ė was a little charged when it arrived (was able to back up my stuff before it died again) but still wasnít charging. I have this laptop down now as being done or fíed for want of a better word. Thought thought would check to see if there was any chance that there was something half simple that might be the problem that wasnít much to fix.

Fujitu Siemens AMILO L7300
__________________

__________________
PC Specs:


Corsair TX550M ENTHUSIAST 550W
Intel B85, S 1150, DDR3, SATA III, PCIe 3.0 (x16), MATX MoBo
Intel Core i7 4790K, S1150, Haswell, 4 Core 4.4GHz Turbo
16GB (4x4GB) Corsair Vengeance Blue DDR3 PC3-12800 (1600)
4GB MSI GTX970 GAMING PCI-E
960G SanDisk UltraII SSD + 2TB SEAGATE Hard Drive
Windows 10

**Spud**
Spud5437 is offline  
Old 09-18-2008, 01:21 PM   #2 (permalink)
Ultra Techie
 
Join Date: Feb 2008
Posts: 999
Default Re: Charging problem

The only thing left after replacing the battery and the AC adapter is the charger circuity on the motherboard.


Just a sample vs repair costs.

Fujitsu Amilo L7300 Motherboard (C510) on eBay, also, Motherboards CPUs, Laptop Accessories, Computing (end time 15-Oct-08 14:21:59 BST)
__________________

KurrentEweser is offline  
Old 09-18-2008, 02:09 PM   #3 (permalink)
Master Techie
 
Alvin.C's Avatar
 
Join Date: Jun 2004
Location: United Kingdom
Posts: 2,580
Default Re: Charging problem

Hello,

1. How old is your laptop?
2. Is it still under warranty?
3. If you remove the battery, and keep your laptop plugged up to the power outlet, does your laptop turn on?
__________________
Alvin.C
linkedin.com/in/alvinwkchan

|Gaming PC| |Dell Latitude E7250| |Macbook Air 13" (Mid 2013)|
|Windows 10 Pro (x64)| |Intel Core i5-6600 @ 3.3 GHz| |MSI NVIDIA GeForce GTX 1080 Gaming X| |Noctua NH-D15S CPU Cooler| |Gigabyte GA-Z170MX-GAMING 5 mATX Motherboard| |Samsung 840 Pro 256GB SSD| |Corsair Vengeance LPX 16GB DDR4-SDRAM| |OCZ ModXStream Pro 700W Modular PSU| |NZXT Vulcan Micro ATX Case|
Alvin.C is offline  
Old 09-19-2008, 05:48 AM   #4 (permalink)
Super Techie
 
Join Date: Jun 2004
Posts: 402
Default Re: Charging problem

Quote:
Originally Posted by Alvin.C View Post
Hello,

1. How old is your laptop?
2. Is it still under warranty?
3. If you remove the battery, and keep your laptop plugged up to the power outlet, does your laptop turn on?
its over the year, out of warranty and no to the third. the power just aint getting there it seems
__________________
PC Specs:


Corsair TX550M ENTHUSIAST 550W
Intel B85, S 1150, DDR3, SATA III, PCIe 3.0 (x16), MATX MoBo
Intel Core i7 4790K, S1150, Haswell, 4 Core 4.4GHz Turbo
16GB (4x4GB) Corsair Vengeance Blue DDR3 PC3-12800 (1600)
4GB MSI GTX970 GAMING PCI-E
960G SanDisk UltraII SSD + 2TB SEAGATE Hard Drive
Windows 10

**Spud**
Spud5437 is offline  
Old 09-19-2008, 02:40 PM   #5 (permalink)
Master Techie
 
Alvin.C's Avatar
 
Join Date: Jun 2004
Location: United Kingdom
Posts: 2,580
Default Re: Charging problem

Quote:
Originally Posted by Spud5437 View Post
its over the year, out of warranty and no to the third. the power just aint getting there it seems
The only thing left to try that I can think of is to test your laptop with another power supply, specifically compatible with your laptop model.
__________________
Alvin.C
linkedin.com/in/alvinwkchan

|Gaming PC| |Dell Latitude E7250| |Macbook Air 13" (Mid 2013)|
|Windows 10 Pro (x64)| |Intel Core i5-6600 @ 3.3 GHz| |MSI NVIDIA GeForce GTX 1080 Gaming X| |Noctua NH-D15S CPU Cooler| |Gigabyte GA-Z170MX-GAMING 5 mATX Motherboard| |Samsung 840 Pro 256GB SSD| |Corsair Vengeance LPX 16GB DDR4-SDRAM| |OCZ ModXStream Pro 700W Modular PSU| |NZXT Vulcan Micro ATX Case|
Alvin.C is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing software in windows xp pro imagesmith Microsoft Windows and Software 3 02-20-2008 02:46 PM
Serious computer problem. HeeRoMaKi Hardware Repairs and Troubleshooting 71 07-28-2007 11:42 PM
Wireless Problem! dropper Computer Networking and Internet Hardware 3 07-08-2007 04:58 PM
Dhcp leasing problem Kloppstock Computer Networking and Internet Hardware 12 05-13-2007 07:13 PM
cant find the problem... Jhill1 Hardware Repairs and Troubleshooting 13 05-07-2007 04:51 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.