Your first graphic card? - Page 8 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Closed Thread
Thread Tools Display Modes
Old 07-08-2005, 08:26 AM   #71 (permalink)
Super Techie
Join Date: Aug 2004
Posts: 435

I had 64mb onboard in my laptop but my first actual card is a 6600GT which im using now

chrisgill369 is offline  
Old 07-08-2005, 08:27 AM   #72 (permalink)
Super Techie
Join Date: Jun 2005
Posts: 274

First video card that was in a computer I owned was a


The funny thing is these days you can find better PCI cards then that would work on a AGP 1x/2X.

mgoldb2 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:34 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.