water killed my computer part 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 05-23-2005, 11:11 PM   #1 (permalink)
Ultra Techie
 
Join Date: Oct 2004
Posts: 582
Default water killed my computer part 2

ok, so ive tested thouroughly and found that my motherboard is gone. good news is that my 300$ worth of RAM is still good... however i wouldnt be writing just to tell you this, i need help... from ANYONE who owns an EVGA geforce 6800GT.

whenever i go to run the card it makes a high pitched squeal out of its small speaker. i dont know if perhaps for some reason it is doing this because it has no fan attached to it anymore since i attached a water-cooling heat-sink to it... im about to call it quits on water-cooling altogether, if this doesnt pan out soon.

the motherboard frying isnt so bad being as im planning on moving to venice core 64 soon. but losing my 400$ graphics card would make me very sad, so any ideas would be fine, i cant put the old heatsink fan and all that on, being as it got damaged after i removed it.

any ideas?
__________________

__________________

The World is my trashcan and i intend to fill it...
Leonidas is offline  
Old 05-23-2005, 11:24 PM   #2 (permalink)
Techie Beyond Description
 
Nubius's Avatar
 
Join Date: Aug 2004
Posts: 11,600
Default

make sure that it's in the socket right and that you've got the power connector plugged to it, not only that make sure that you've got a power connector that't isn't also powering Hard drives or crap like that....you need a line purely for the graphics card and nothing else...I've got water cooling on my machine as well dude, they wouldn't make a graphics card have their little PC speaker go off just from a fan not being plugged in because they are aware of plenty of people who want to water cool them.

So if none of that works, then you just need to RMA it which isn't that big of a deal man, it's not like the card is just completely lost.
__________________

Nubius is offline  
Old 05-23-2005, 11:27 PM   #3 (permalink)
Ultra Techie
 
Join Date: Oct 2004
Posts: 582
Default

i can RMA it? even tho i removed the heatsink? and how do i go about this exactly, contact newegg?
__________________

The World is my trashcan and i intend to fill it...
Leonidas is offline  
Old 05-23-2005, 11:30 PM   #4 (permalink)
Lord Techie
 
Join Date: Jan 2005
Posts: 8,013
Send a message via AIM to DJ-CHRIS
Default

no contact eVGA

Reattatch the heatsink
DJ-CHRIS is offline  
Old 05-23-2005, 11:39 PM   #5 (permalink)
Techie Beyond Description
 
Nubius's Avatar
 
Join Date: Aug 2004
Posts: 11,600
Default

yeah, what chris said.......just put the heatsink on properly and don't completely screw it up and make it look like you physically damaged the card and you'll be fine......if you've had it within like 90 days then newegg will probably replace it as well....then if THAT one breaks down you can try eVGA almost double guarantee
Nubius is offline  
Old 05-24-2005, 05:28 AM   #6 (permalink)
Ultra Techie
 
Join Date: Oct 2004
Posts: 582
Default

ok, my stylized graphic cover thing for my card is permanently damaged... is there any other alternative? will they still replace it?
__________________

__________________

The World is my trashcan and i intend to fill it...
Leonidas is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.