USB Multi-Channel Audio Device Error! Device Manager! Blue Icicle preamp+ Microphone set-up.. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Thread Tools Display Modes
Old 01-15-2013, 08:19 PM   #1 (permalink)
Virgin Techie
Join Date: Jan 2013
Location: Maryland
Posts: 2
Unhappy USB Multi-Channel Audio Device Error! Device Manager! Blue Icicle preamp+ Microphone set-up..

Question One! ~~~ I have a USB to XLR studio microphone converter, the Blue Icicle that's not working correctly anymore! Very odd. It worked before, than I reformatted my entire computer and it had stopped working. I have not tried the device on another computer yet. I updated my BIOS to latest version, installed for the most part important drivers. The Blue Icicle is not supposed to have any downloaded or installed drivers besides it's basic ones. When I try to uninstall and reinstall the drivers from device manager, but to no avail.

The Blue Icicle+AT2020 XLR Mic doesn't appear at all!

Uninstalling from device manager and re-plugging in the Blue Icicle still leads to trouble, saying the installation failed. I also tried download the device drivers of USB Multi-Channel Audio Device from CNET, yet to NO FIX.

Question Two! ~~~ I am still confused on how to install certain drivers on my desktop aswell, that you usually install on a motherboard's manufacturer website that doesn't have a setup or install, but usually contain only .txt and .bat files. I'm not dumb when it comes to computers but this has me stumped for hours now.

I am just hoping with someone who has had similar problems with their computers to be able to aid me. I'm not sure if this information will be of any aid but this is my current motherboard
GIGABYTE - Motherboard - Socket 1366 - GA-X58A-UD3R (rev. 2.0)

motherboard info on desktop

These are pictures of my current problem with Device Manager. -----> Device manager + yellow exclamation sign. ----> error codes.

Whomever can help me and anyone who answers, thank you very much!
If you need more information, please ask!

Edit, I fixed the Root Enumerator problem. Uninstalled and restart, it disappeared. Blue Icicle still giving trouble.
TooLongButStillRead is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:21 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.