troubles after cleaning out dust - Page 3 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 07-13-2005, 02:35 PM   #21 (permalink)
True Techie
 
Join Date: Nov 2004
Posts: 189
Send a message via AIM to TSXmike
Default

Quote:
Originally posted by joshd
just get a new psu for ur pc. we have all seen the warnings... never get a generic psu, which i assume urs is, as you said it was very cheap.
what would be a good brand of psu? im probley gonna buy it off newegg if that helps...

i should probley go with a 500w this time... just to be ready for upgrading if need be
__________________

__________________
******************************
Abit AN8 32x
Athlon 64 3500+
eVGA 7900gto (x2)
kingston DDR400 512x2
WD 300gb + WD 120gb
Antec Neo HE 550w
win xp pro
******************************
TSXmike is offline  
Old 07-13-2005, 03:15 PM   #22 (permalink)
Master Techie
 
Join Date: Jun 2005
Posts: 2,134
Default

yea. i only have a dell psu so i dont know that much...

guys?
__________________

joshd is offline  
Old 07-13-2005, 03:57 PM   #23 (permalink)
Monster Techie
 
Join Date: Apr 2005
Posts: 1,946
Send a message via AIM to Static_11 Send a message via Yahoo to Static_11
Default

umm wattage means nothing when it comes to psu's... its mostly trhe quality... if you buy a 50 dollar 500W ( im guessing prices here ) generic brand... and a 75 dollar 500W name brand... guess what one will faill u? the generic... the namebrand owns over all others whne it comes to psu.. so make sure its a good brand instead of some cheapie 10 dollar
Static_11 is offline  
Old 07-13-2005, 04:17 PM   #24 (permalink)
True Techie
 
Join Date: Nov 2004
Posts: 189
Send a message via AIM to TSXmike
Default

what brands should i look for?

gimmie some examples
__________________
******************************
Abit AN8 32x
Athlon 64 3500+
eVGA 7900gto (x2)
kingston DDR400 512x2
WD 300gb + WD 120gb
Antec Neo HE 550w
win xp pro
******************************
TSXmike is offline  
Old 07-14-2005, 02:26 PM   #25 (permalink)
True Techie
 
Join Date: Nov 2004
Posts: 189
Send a message via AIM to TSXmike
Default

bump
__________________

__________________
******************************
Abit AN8 32x
Athlon 64 3500+
eVGA 7900gto (x2)
kingston DDR400 512x2
WD 300gb + WD 120gb
Antec Neo HE 550w
win xp pro
******************************
TSXmike is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.