"Think DMA is enabled? Wrong...try again." - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
Thread Tools Display Modes
Old 10-11-2003, 02:01 PM   #1 (permalink)
True Techie
Join Date: May 2003
Posts: 223
Default "Think DMA is enabled? Wrong...try again."

I wanted to share this tweak I did in XP Pro that gave me significant benfits - I'm not sure if I'm just late in the game knowing about this, but here it is...

I thought I had correctly enabled DMA for my drives, but after reading the following xteq tweak I realized I had not... My machine is MUCH zippier now. Hope this helps those out there like me, who thought DMA was enabled correctly. This tweak is from XTEQ and it is completely free - have had no problems using this program for about a year now, and it has very good recording/fail options(which I haven't had to used yet).

Be aware the following quote and changes to the registry and used IN CONJUNCTION with the software, so I don't think you can just change these mentioned registry changes - I don't know what else the program is doing/adding... Here is a small(99k) screen/app capture which I hope will better help you know what I mean. Screen Capture of App

Plugin Created by CAv Edwards, mailto:SEFADMWJNXNM@spammotel.com

Setting #1 - 10: Enable UDMA 66 for all devices enumerated in the registry.

Settings take effect after reboot.

Don't skip over this part thinking, "oh I already know this one". Chances are, you haven't got it properly enabled. "DMA stands for Direct Memory Access and allows IDE hard drives and CDROMs to access the system memory directly thus bypassing the CPU. This can free up CPU resources when multitasking or utilising very CPU intensive applications.

Right-click My Computer > Properties > Hardware Tab > Device Manager "Double click the IDE channels you want to enable DMA for.

In the drop down box select DMA if available. If you experience any problems accessing your hard drive/CDROM after enabling DMA this way then turn it off. "Ok, you now think DMA is enabled? Wrong...try again.

You now need to enable DMA in the registry. "HKEY_LOCAL_MACHINE > SYSTEM > CURRENTCONTROLSET > CONTROL > CLASS > {4D36E96A-E325-11CE-BFC1-08002BE10318}

There may be a few subdirectories called 0000, 0001, 0002, 0003 "In each of them (it does not matter how many you have as long as it is in all of them) add a new DWORD value.

Call it EnableUDMA66 "Give it a decimal value of 1 to enable DMA. Reboot to see changes.

Note that you may already have this registry entry, depending on certain chipset drivers. Whatever the case, it's worth checking to see

There is no reason for any individual to have a computer in his home.
President, Digital Equipment, 1977
chalk is offline  
Old 09-28-2004, 07:02 AM   #2 (permalink)
PowerQuest / Opera
TheMajor's Avatar
Join Date: Jun 2004
Location: Netherlands
Posts: 10,177

yeak, X-setup is very good!!! it has far more options than tweakUI
TheMajorMMX - Intel P200 MMX @ 225Mhz - V-Tech (PcPartner) Baby-AT mb w/ Intel Triton TX chipset - Nvidia Riva TNT2 M64 w/ 16MB - 256MB M-Tec SDRAM - Still running.....
TheMajor is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:36 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.