System running slow... - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 04-06-2005, 12:09 AM   #1 (permalink)
Ultra Techie
 
Join Date: Aug 2004
Posts: 592
Question System running slow...

I've owned this system since September, and it seems like its never really been running as fast as I expected it too. I don't know, maybe im just expecting to much. (System is listed below in sig). I installed Farcry the other day cause I wanted to start playing it again, and the game runs very slow. I have to use the "Optimal Settings" that the confiuration menu defines, to even get the game to look half decent. I mean in low settings the backrounds don't ever fully load, and I get black spots on the screen where it hasn't loaded. Also the game is extremely bright in the places where the sun shows. I have also noticed that my systems takes its time loading games, booting, and doing every day normal tasks like getting on the internet n such. So around November I bought a 10,000k Western Digital Raptor Drive to see if it would speed things up, if anything it seems like it slowed things down. Is my system already outdated for future games? Cause I almost feel like saving up my money and getting a better video card, some name brand ram, and a half decent socket 939 CPU. I don't know if that would improve anything, or if I am just expecting to much. Here is my score from 3DMark05, 3276. Any suggestions on a way to improve preformance? Or is it time to be looking in to faster hardware?
__________________

__________________
ASUS P8Z68 Deluxe
Intel Core i7 2600k
16GB DDR3 G-Skill Ripjaws
1TB 7200 Segagte Drive
eVGA GeForce 570
Samsung Blu-Ray Drive
Antec 850 Watt PSU
Windows 7 Professional
Blackmoore is offline  
Old 04-06-2005, 12:19 AM   #2 (permalink)
Techie Beyond Description
 
Apokalipse's Avatar
 
Join Date: Jun 2003
Location: Melbourne, Australia
Posts: 14,559
Default

for a system like yours, I can say it is definately not your hardware

try installing the latest video drivers and installing DirectX 9.0c
also, what provgrams are running in the background
__________________

__________________
Apokalipse is offline  
Old 04-06-2005, 12:24 AM   #3 (permalink)
True Techie
 
Join Date: Feb 2005
Posts: 165
Default

Do a Drive re-format and before you even hook it up to the net again pop in the security disk (mcafee, norton what ever) also i recommend not downloading music on to this comp cause it could be loading your comp with spy wear and other junk that drastically lowers your speed. Use a cheap *** 200 dollar comp witha big HD for downloading it and use it almost like a radio.

If that does not work im not sure what could be wrong with the comp, go and check all the internals but if a reformat and new HD dont work i have no idea.
ki9090 is offline  
Old 04-06-2005, 12:38 AM   #4 (permalink)
Wizard Techie
 
Join Date: Feb 2005
Posts: 3,220
Default

probably spywares and stuff

go to www.microsoft.com and search "antispyware beta" and download it and run it, it's great stuff (i had thousands of spywares killed on a 2yr old comp)
__________________


Quote:
I don\'t play for fun, I play to win and winning is fun.
diabloII is offline  
Old 04-06-2005, 01:04 AM   #5 (permalink)
Grandfather of Techist

\_(ツ)_/
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,302
Default

Start--> Run--> type "msconfig"-->Enter--> Startup tab--> uncheck everything except for your antivirus, firewall, and any drivers or software that you absolutely need (broadband and such)--> Apply--> Restart.

You should really see a hge difference if you have never pared down your autostarts.

Be sure to download Microsoft's AntiSpyware as was suggested above, and use it. Adware and spyware can really drag down a computer's speed.
__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is online now  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.