Squeaking Monitor - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Closed Thread
Thread Tools Display Modes
Old 06-04-2005, 06:06 PM   #1 (permalink)
Newb Techie
Join Date: Jun 2005
Posts: 1
Default Squeaking Monitor

I have an old Gateway monitor (EV700). It has worked fine for years, but now it will not display anything. When the monitor is plugged in the green power light flashes and there is a squeaking coming from the back of the monitor. I can not even pull up the monitor configure box with the dial in the front. I'm guessing the monitor is shot, but if anyone has a suggestion for fixing it, that would be excellent.

akwakeboard is offline  
Old 06-04-2005, 07:00 PM   #2 (permalink)
Ultra Techie
Join Date: Apr 2004
Posts: 858


GageMW is offline  
Old 06-04-2005, 09:14 PM   #3 (permalink)
The Grinch
c0rr0sive's Avatar
Join Date: Feb 2005
Location: asdf
Posts: 8,688

It's dead.
c0rr0sive is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:14 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.