Newegg problems? - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Closed Thread
Thread Tools Display Modes
Old 01-24-2006, 05:06 AM   #11 (permalink)
True Techie
Join Date: Jan 2006
Posts: 129

I went there now just for the sake of checking and it's fine for me, wow it's like the first time ive gone here casually so I guess i'll check it out.

filocardhustler is offline  
Old 01-24-2006, 05:07 PM   #12 (permalink)
Ultra Techie
ulater6000's Avatar
Join Date: Jan 2006
Location: Alaska
Posts: 757
Send a message via AIM to ulater6000 Send a message via Yahoo to ulater6000

The only problem I have with newegg is there new search system.

CompTIA A+, CompTIA Network+, Cisco CCENT, Cisco CCNA Routing & Switching
ulater6000 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:34 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.