MIC. Problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 01-21-2006, 03:30 PM   #1 (permalink)
Ultra Techie
 
Join Date: Mar 2005
Location: Illinois
Posts: 609
Default MIC. Problem

Just picked up a Mic today. Haven't really used one before. I plugged into my Audigy ZS2, and now everytime I talk into my MIC I hear myself through my speakers and my sub goes nuts... Ummm I thought you were supposed to talk into it and other people can hear you, not urself... LOL WTF Is wrong with this thing? I tried switching ports to other things on my sound card and still no work. It dont even register on the other ports. What can I do? (the other ports arent mic ports.)
__________________

•AMD 8120 @ 3.8Ghz
•CoolerMaster Hyper212 EVO
•MSI 970A G46
•8GB Dual-Channel 1600Mhz DDR3 Corsair Vengeance
•eVGA 660 GTX Ti
•128gb Samsung 830 SSD (OS, Games)
•2TB Seagate 7200rpm 64mb Barracuda SATA6GB's
•640gb WD (Cavier Blue)
•CoolerMaster HAF-X
AuThoRitY is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.