little help with my internet browser - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Closed Thread
Thread Tools Display Modes
Old 07-31-2005, 11:19 AM   #1 (permalink)
True Techie
DarkMassacre's Avatar
Join Date: Jul 2005
Posts: 174
Default little help with my internet browser

If it makes any difference, I'm using Firefox. My computer has gone screwy all of a sudden. When I have caps lock turned on it is like it is turned off, and when it is off it is really on. And on the internet whenever I click on a link or anything to go to a new page it always opens it up in another window. Even clicking on "post a topic" does it. Any idea whats going on and How I can fix it?

EDIT: Nevermind. Everything is back to normal now. That was odd.
And if we fall, we all fall, and we fall alone
DarkMassacre is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:52 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.