Infamous 'Screech of Death' - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 10-13-2003, 04:47 PM   #1 (permalink)
True Techie
 
Join Date: Oct 2003
Posts: 112
Send a message via AIM to Zero Shift
Question Infamous 'Screech of Death'

Hey all.
I was just wondering if the 'Screech/Squeal of Death' issue for Creative Sound Blaster Audigy/Audigy2 cards was ever resolved.
As an owner of an Audigy 2 that consistently crashes my computer (when i bother to try to get it to work...), I have been searching frantically for some savior out there to post a solution, or 3rd-party driver for the masses whose ears still ring from the evil, horrid noise that spouts from the speakers connected to these (rather expensive) sound cards.
Can someone post such a solution, and keep us unfortunates from tossing these $150 (at the time of purchase) sound cards in the trash?



For emphasis, here is the expression I make every time my innocent gaming is interrupted by this foul noise.....
Attached Images
File Type: jpg cpuz2.jpg (38.2 KB, 65 views)
__________________

__________________
NZXT Guardian Case with Thermaltake PurePower 420w
FIC AU13 motherboard
AMD Athlon XP 2600+ 333FSB (Barton) with Thermaltake Silent Boost HSF
WDC 80Gb 8Mb cache 7200rpm
512Mb Kingston Dual-channel PC3200
MCP-T SoundStorm audio (integrated)
ATi Radeon 9800 Pro (it owned, until x800 and 6800)
Logitech Z-680 5.1 speaker system (integrated Dolby Digital 5.1, DTS, Pro Logic II decoding)
Logitech Cordless Elite Duo keyboard & mouse
Saitek Cyborg Evo joystick
Windows XP Pro SP1 (dont. install. SP2.)
Zero Shift is offline  
Old 10-13-2003, 07:32 PM   #2 (permalink)
Wizard Techie
 
Join Date: Jul 2003
Posts: 3,937
Default

i have no advice for you, but is this happening to all the audigy/ audigy 2 sound cards bought or is this problem just with a few people who bought this card?

i heard they were having problems with there drivers but this sounds pretty bad. have you contacted creative tech support?
__________________

ekÆsine is offline  
Old 10-13-2003, 08:01 PM   #3 (permalink)
True Techie
 
Join Date: Oct 2003
Posts: 112
Send a message via AIM to Zero Shift
Default

this is not happeneing to all Audigy/2s out there, but i know a few people personally who have the same problem, and have found an online petition for better Creative customer service from many, many people who have the same problem.
which brings me to your second question.
Ohhhhhh the hours spent emailing Creative tech support.
And waiting for their responses, which can take as long as a day.
Waiting a whole day simply for 'try using a different PCI slot.'

Which didn't work, btw.
Updating drivers, resetting the BIOS, re-installing the main driver only....
None of their suggestions worked.
And worst of all, after they told me to disable all services (which left me with no internet access due to my wireless connection, a bland desktop due to no StyleXP theme service, and a bad taste in my mouth)
They simply stopped responding to my emails.

If anyone can find any new information, it's being posted/linked to from here would be greatly appreciated.


P.S. - to see how widespread the problem is, google up 'Squeal of Death' with quotes
__________________
NZXT Guardian Case with Thermaltake PurePower 420w
FIC AU13 motherboard
AMD Athlon XP 2600+ 333FSB (Barton) with Thermaltake Silent Boost HSF
WDC 80Gb 8Mb cache 7200rpm
512Mb Kingston Dual-channel PC3200
MCP-T SoundStorm audio (integrated)
ATi Radeon 9800 Pro (it owned, until x800 and 6800)
Logitech Z-680 5.1 speaker system (integrated Dolby Digital 5.1, DTS, Pro Logic II decoding)
Logitech Cordless Elite Duo keyboard & mouse
Saitek Cyborg Evo joystick
Windows XP Pro SP1 (dont. install. SP2.)
Zero Shift is offline  
Old 10-13-2003, 09:45 PM   #4 (permalink)
Older But Wiser
 
kboy's Avatar
 
Join Date: Jul 2003
Location: So. Cal
Posts: 1,041
Default

I've used Soundblaster cards for years and it seems like there was always some issue with drivers for certain games or whatever. Games stuttering, resetting to desktop, etc.. I finally got the ASUS Mobo A7N8X-Deluxe and use their On-Board sound capabilities and removed the Soundblaster Audigy card. Works for me, The way I look at is another PCI slot freed up and no IRQ issues... Good Luck my friend!
__________________
ASUS Sabertooth 990FX
AMD FX-8150
16 GB Ram
ASUS GeForce 760 GTX


1TB Sata Seagate
100 Gig Maxtor Sata 7200 Rpm
ASUS DRW 24B3S7 ATA Optical
Windows 7 Home Premium
Dell E228WFP 22"
kboy is offline  
Old 10-14-2003, 06:28 AM   #5 (permalink)
Wizard Techie
 
Join Date: Jul 2003
Posts: 3,937
Default

kboy just give it a few days while trying to play some games and using winamp. i have the same mobo, the sound on it is horrible. i had to disable the hardware acceleration with the sound card otherwise i would get choppy music or echoing sounds in vice city and some sound effects were quiet. yes i even have the no cd patch!

zero shift it doesn't seem like they have a fix out yet for this yet. you would think that by acident they would get the drivers right one of these days. i would check on other forums that have knowledgable audiophiles who are familair with creative cards. i'm not sure that there are many guys here that would be able to help you with this problem, good luck with the fix
ekÆsine is offline  
Old 10-14-2003, 10:39 AM   #6 (permalink)
Older But Wiser
 
kboy's Avatar
 
Join Date: Jul 2003
Location: So. Cal
Posts: 1,041
Default

I'm just using 2 speakers and a subwoofer, nothing fancy. If I was using the 5.1 formula Then I would definitely use a Soundblaster environment and deal with their driver issues Ek.
__________________
ASUS Sabertooth 990FX
AMD FX-8150
16 GB Ram
ASUS GeForce 760 GTX


1TB Sata Seagate
100 Gig Maxtor Sata 7200 Rpm
ASUS DRW 24B3S7 ATA Optical
Windows 7 Home Premium
Dell E228WFP 22"
kboy is offline  
Old 10-15-2003, 08:20 AM   #7 (permalink)
True Techie
 
Join Date: Jul 2002
Posts: 154
Send a message via Yahoo to daveppeters
Default

Zero Shift - do you have a mic plugged into your card? If it is too close to the speakers, or the volume is up too high, it will cause a feedback loop - which sounds like a horrible screeching noise.
__________________
IWill XP-333 / 384MB PC2100 DDR / AMD T-Bird 1.33GHz (o/c to 1.40 until I get a better CPU cooler!) / VisionTek GeForce4 MX440 / SB Live! X-Gamer 5.1 / Maxtor 20GB 7200 RPM HD / Toshiba 8X DVD / Sanyo 40/12/40X CD-RW / Win XP Home

http://www.statgfx.com/statgfx/foldi..._original&.jpg
daveppeters is offline  
Old 10-15-2003, 11:29 AM   #8 (permalink)
True Techie
 
Join Date: Oct 2003
Posts: 112
Send a message via AIM to Zero Shift
Default

Ahhh, it's not a feedback loop. The 'Squeal of Death' includes said squeal, a loop of some of the last sound effects played, and a locked-up system.

It was originally thought to be an issue with certain VIA chipsets, but i've seen plenty of threads with angry users who have the problem on Intel and SiS chipsets too, so it almost sounds like buying an Audigy/2 is a game of russian roulette with your motherboard's chipset.
__________________

__________________
NZXT Guardian Case with Thermaltake PurePower 420w
FIC AU13 motherboard
AMD Athlon XP 2600+ 333FSB (Barton) with Thermaltake Silent Boost HSF
WDC 80Gb 8Mb cache 7200rpm
512Mb Kingston Dual-channel PC3200
MCP-T SoundStorm audio (integrated)
ATi Radeon 9800 Pro (it owned, until x800 and 6800)
Logitech Z-680 5.1 speaker system (integrated Dolby Digital 5.1, DTS, Pro Logic II decoding)
Logitech Cordless Elite Duo keyboard & mouse
Saitek Cyborg Evo joystick
Windows XP Pro SP1 (dont. install. SP2.)
Zero Shift is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.