Help with ATI Radeon 9700 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Closed Thread
Thread Tools Display Modes
Old 04-24-2005, 04:30 PM   #1 (permalink)
Newb Techie
Join Date: Apr 2005
Posts: 7
Send a message via AIM to headtrip
Default Help with ATI Radeon 9700

The other night, I was playing a pretty high graphic demanding game, and all of the sudden the picture on my monitor distorted. I have heard of fans going out in ATI cards quite frequently, so I assumed that my VGA chip was overheating and promptly turned off the computer. I opened my case and supplied power to see if the fan on the card was working, and it was not. So in hopes of saving my card, I bought a new VGA fan from Fry's Electronics. I properly installed it and put the card back into my case and booted. The image is better, but I still see some distortion in the display. I've hosted an image of what it looks like on my desktop currently. The url is . I was just curious if my VGA chip is permanently messed up or if this is repairable? Or even perhaps something minor that I may have overlooked is causing this problem. Any suggestions on comments in relation to my problem would be greatly appreciated.

headtrip is offline  
Old 04-24-2005, 04:32 PM   #2 (permalink)
Monster Techie
Join Date: Feb 2005
Posts: 1,363

Try updating the graphics. I think you fried something.


Ricer: from the latin word Ricarius meaning to suck at everything you attempt.
desiboi is offline  
Old 04-24-2005, 04:36 PM   #3 (permalink)
Master Techie
Shumway's Avatar
Join Date: May 2004
Location: London - Ontario - Canada
Posts: 2,729

Try updating your driver's and see what happen's,But like desiboi said i think you kind of fried the card.
Shumway is offline  
Old 04-24-2005, 05:04 PM   #4 (permalink)
Ultra Techie
Join Date: Dec 2004
Location: New Brunswick, Canada
Posts: 511
Send a message via MSN to LegendBreath

Yeah, they are right... indeed, you fried something... it's not normal for a video card to act like that.
LegendBreath is offline  
Old 04-24-2005, 05:21 PM   #5 (permalink)
Newb Techie
Join Date: Apr 2005
Posts: 7
Send a message via AIM to headtrip

If by fry, you mean perhaps melted the VGA chip, I understand. Also, it's not like I purposely friend it. Like I stated before, I have had many friend's have this same fan go out for no apparent reason. One of them, the card was only 2 months old. So I don't really know, I've opened a support ticket with ATI, and I guess I'll follow that. Thanks for the replies
headtrip is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:58 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.