Techist - Tech Forum

Techist - Tech Forum (
-   Monitors, Printers and Peripherals (
-   -   Hard Disk not recognised. (

ralphie7 04-04-2005 03:33 PM

Hard Disk not recognised.
I have recently purchased a Seagate Barracuda 7200.7NCQ Serial ATA .160GB hard drive
my problem is I can't get my computer to recognise it.
I also fitted an Adaptec Serial ATA 120SA card.
i have tried booting it up with my Windows xp professional system disk but that doesn't work.

my system is
processor = Athlon XP 1255 MGz
motherboard = MSI K7N2 DELTA-ILSR
Ram = 1.12gb
Hard drive = Seagate Barracuda SATA 160GB
Operating System = Windows XP Professional

I have downloaded LIVE UPDATE from MSI
and updated the drivers
flashed the bios

the Adaptec cd that came with the Card is supposed to create a bootable disk but i can't get it to do this.
i have tried seagate sea tools also but still no luck

if i put the old hard drive back the computer recognises that.

any help would be appreciated as i am nowhere near as knowledgable as you guys.

Trifid 04-04-2005 03:41 PM

You need to get a floppy disk and put the sata driver on it or find the ones that came with your motherboard/harddrive.

edit: here are the drivers:

Samm 04-04-2005 06:44 PM

You said when you put the old drive back in, system recognises that - is the old drive standard ATA with windows installed on it?

Correct me if I'm wrong but it sounds like you are trying to install windows on the s-ata drive without a standard ide drive in the system.

If so, when you install XP from the CD, you need to press F6 in the setup screen to install scsi/raid controllers. You should then be able to insert the driver floppy disk & install the s-ata driver.

If you can't create this disk from the CD that came with the card, go to this link to download it instead. (I'm guessing you have the 1205SA card as 120sa doesn't seem to exist :

I suggest if you still have problems with it, then boot windows from your IDE drive & see if you can install the driver for the card from there.

ralphie7 04-04-2005 10:17 PM


thanks for the help
i tried to download from the link but it
wouldn't save to a floppy as it said the floppy
hadn't enough space on it.


thanks for the help
sorry yeah its an ADAPTEC 1210SA card
it came with a CD from which it said I could produce
a floppy to load drivers.
that done i would then
Put the Windows system CD in and press F6 when prompted.
then press S and insert the floppy and press enter
but using the ADAPTEC CD i don't get to the point where I
can create the floppy. it hangs with the CAPS LOCK and SCROLL LOCK lights both flashing together.

i used the link you gave me but looked for similar downloads but for the 1210SA all went ok. created the floppy but when i used it in the Windows install it gave me the message
the file TXTSETUP.OEM could not be found. Unable to continue.Press any key.

i really appreciate this guys believe me.

ralphie7 04-06-2005 11:23 AM

right i have managed / muddled to get a bit further.
i managed to create the driver floppy disk with the Adaptec cd that came with the controller.the only way i could do this was to use the old hard drive hooked up.

i then powered up the pc with the Windows XP Professional system disk in. i pressed F6 when prompted for third party drivers.
i was asked to insert the floppy with the drivers and press enter.
it then progressed ok until it thru up the following error message.

file\win2000\aar1210.sys caused an unexpected error ( 4096 ) at line 2108 in d:\xplient\base\boot\setup\oemdisk.C.
press any key to continue

pressing any key takes you back to the point you insert the floppy.

Any help would be great guys

Samm 04-06-2005 02:17 PM

First thing to check is that the drive is being recognised correctly by the system - press CTRL+A when promted after boot up to enter the controller utility.
The drive should be detected in here. You also need to format the drive using this utility if you haven't done so already.

If thats all OK, next thing to check is :
The floppy disk - make sure you use a brand new floppy (or fully format an old one & ensure no bad sectors) for the driver disk.

When you've pressed F6 to install driver, you need to to need to press 'S' then <enter> to specify that driver is located on the floppy.

Also, while looking on adaptecs website, I found this - it's their solution to the problem you are having :

[The problem is caused by uncompressing the downloaded driver incorrectly.

The correct way is to double click on the downloaded file, click on browse and select the floppy drive A: then select unzip.

This should create a driver disk with the folder "win2000" along with three files HRAIDSK1, TRANS.TBL and TXTSETUP.OEM. These three files should reside in the root directory of the floppy diskette.]

Hope some of this helps!

ralphie7 04-07-2005 12:37 AM

Thanks Samm
thats been a great help
thought you had cracked it for me.It was
the floppy that was causing the problem
with the error message. I have
replaced it and created the driver disk again
all went well no error message this time but
it has now hung at the point the Windows System
disk was formatting the drive it got as far as 86%
before it stopped.
thought it would be ok this time I really did.
now i am stumped again.
any more ideas please

ralphie7 04-07-2005 01:44 PM

ever felt like the answer was right under your nose ?
that's what i feel like.
the question
why does my Windows XP Professional hang while formatting my Seagate Barracuda 7200.7NCQ Serial ATA .160GB hard drive
it is going great until it gets to 86%-88%
then it just hangs - doing nothing
have tried it again and just the same result.

Samm 04-07-2005 04:00 PM

Not certain but Windows XP does have some sort of issue with drives above 128GB. You need to have 48bit LBA compatible bios & also service pack 1 for XP for it to work.

Samm 04-07-2005 04:14 PM

Forgot to add, if your copy of XP does not include service pack 1, you should be able to let windows format it to 128GB. After installation of windows, you will need to install SP1 & the remainder of the unpartitioned disk space should show up. This can then be formatted as a second partition.

The links below might be of help :

All times are GMT -5. The time now is 06:40 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.