The Creative xfi crashing? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 10-08-2008, 09:28 PM   #1 (permalink)
Newb Techie
 
Join Date: Sep 2008
Posts: 10
Send a message via MSN to Thor.
Default The Creative xfi crashing?

Hi all you techies out there, i have a majore problem with my Creative Xfi, ive tried everything from uninstalling the drivers and reinstalling the drivers, still no sound. Im running windows xp 64bit pro and when ever i plug it in after 2 minutes windows crashes, then restarts.

Any clue on whats happening, it also gives hardware error mesages to, fresh install.

heres the link to my model.

Sound Blaster X-Fi Surround 5.1 70SB109000000 - Better Music and Movie Sound, Made Easy

O ya when it crashs it doesn't give any report on what caused the crash. It simply gives fast blue screen of death and restart.
__________________

Thor. is offline  
Old 10-08-2008, 09:34 PM   #2 (permalink)
Newb Techie
 
Join Date: Sep 2008
Posts: 15
Default Re: The Creative xfi crashing?

Return and Receive... a new one...

Best thing I can think of is a manufacturer defect.
__________________

P4R4S1T3 is offline  
Old 10-08-2008, 10:16 PM   #3 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: The Creative xfi crashing?

Did you remove the drivers with Driver Cleaner Pro? It could be that the old drivers are still installed and that is why the new drivers are not taking priority and you still get noe sound.

Driver Cleaner Professional download from Guru3D.com
__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 10-08-2008, 11:40 PM   #4 (permalink)
Newb Techie
 
Join Date: Sep 2008
Posts: 10
Send a message via MSN to Thor.
Default Re: The Creative xfi crashing?

yes i always remove the drivers before uninstall. Its sad its a great soundcard, when it worked, my mp3's never sounded better. Nothing beats 24bit encoding and openal.
Thor. is offline  
Old 10-09-2008, 05:11 AM   #5 (permalink)
Lord Techie
 
ricanflow's Avatar
 
Join Date: Feb 2006
Location: Euless, Tx
Posts: 6,317
Default Re: The Creative xfi crashing?

Did you change anything in your computer lately???
__________________
3DMARK06 = 20,341 (3.8GHZ)



Laptop
P7350 | GTX 260M | 4GB DDR2 800 | 320GB HD | X-Fi | Vista 64

Folding Rig/File Server

M775 | E1200 | Foxconn P9657AB
| Dual 8800GT | Antec NeoHE 500 | Barracuda 80GB | Wintec Ampx



ricanflow is offline  
Old 10-09-2008, 05:25 AM   #6 (permalink)
Hellfire!
 
Wildside's Avatar
 
Join Date: Jan 2007
Location: Riverside, CA
Posts: 3,038
Send a message via MSN to Wildside
Default Re: The Creative xfi crashing?

sound card crashes my PC sometimes, disables sometimes on its own and have to restart to fix it, reinstalling drivers wont do anything.

Creative Labs need to fix their drivers badly.
__________________
--Windows 10 Pro 64-Bit
--AMD Ryzen 1700x @ 3.4GHz w/ MX-4 and Corsair Hydro 100i Liquid Cooler
--Corsair LPX Vengeance Black 16GB (2 x 8GB) DDR4 3200 DRAM
--EVGA GeForce GTX 960 SuperSC ACX 2.0+ 2GB GDDR5
--ASUS Crosshair IV Hero AM4 X370 Motherboard
--WD BLACK SERIES WD2003FZEX 2TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" HDD
--SAMSUNG 840 EVO MZ-7TE250BW 2.5" 250GB SATA 6Gb/s SSD
--Corsair Obsidian 750D Black Aluminum / Steel ATX Full Tower Computer Case
--Corsair Professional Series 860-Watt AX860
Wildside is offline  
Old 10-09-2008, 05:01 PM   #7 (permalink)
Lord Techie
 
ricanflow's Avatar
 
Join Date: Feb 2006
Location: Euless, Tx
Posts: 6,317
Default Re: The Creative xfi crashing?

Windows Xp drivers are rock solid and very stable, no crashes no static nothing.

Vista just sucks in the sound area, it doesn't have directsound anymore which is part of the problem. Haven't heard of any problems with XP64 driver either.
__________________

__________________
3DMARK06 = 20,341 (3.8GHZ)



Laptop
P7350 | GTX 260M | 4GB DDR2 800 | 320GB HD | X-Fi | Vista 64

Folding Rig/File Server

M775 | E1200 | Foxconn P9657AB
| Dual 8800GT | Antec NeoHE 500 | Barracuda 80GB | Wintec Ampx



ricanflow is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Creative Zen 2GB Oreo Buy/Sell/Trade and Hot Deals 0 05-30-2008 10:55 AM
Creative stops 3rd party Vista drivers for legacy product Harper Monitors, Printers and Peripherals 12 04-10-2008 10:13 PM
Battlefield 2 (et al) crashing. Talbot General Gaming 21 07-10-2007 03:41 AM
CPU Usage And Crashing, svchost.exe sucking up CPU Usage Bahamut Monitors, Printers and Peripherals 10 05-30-2007 06:01 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.