creative sound driver issues. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 11-09-2004, 03:51 PM   #1 (permalink)
Junior Techie
 
Join Date: Jul 2004
Posts: 70
Default creative sound driver issues.

I have finally come to the conclusion that creative driver issues are over the top and do not plan on supporting them in the future by buying there products. The clicking popping hissing issues, the unstability of there latest drivers, the mishmash of new drivers on there download site, bsod's, no WHQL certification has convinced me it's time to move on. I have an old audigy gamer in my current system and it has been problematic from the get go. Enough is enough!

My question to the forum is concerning onboard sound. I have just purchased a A7N8X-E Deluxe motherboard and am curious of any who have had any experiences with the onboard sound it includes?

If I find the onboard sound inadequite I plan with going with a Turtle Beach card. How are the drivers for the TB cards?

It is sad that the preimmenant producer of sound cards ( creative ) can't get there act together and produce a set of stable, trouble free drivers. There forums are loaded with user issues related to shoddy drivers.

Any comments or suggestions appreciated.
Bye bye sound blaster!
__________________

__________________
nothing ventured.......nothing gained
Kaniver is offline  
Old 11-09-2004, 11:26 PM   #2 (permalink)
Banned
 
Join Date: Apr 2004
Posts: 559
Default

What kind of graphics card do you have? If it's an ATI, then that could be the problem. The ATI's like to override the BIOS's PCI latency setting. They tend to run at 255 clk instead of 32-48 clk like they should be. The clk is a system timer, known as a "time slice".. Each card in the system gets a certain amount of time to transfer data on the PCI/AGP bus.. However if one card is set very high it can hog the bus and cause problems. This is very true with creative sound cards.

Let me know if any of this sounds like it could be your problem.
__________________

ChaosBlizzard is offline  
Old 11-09-2004, 11:47 PM   #3 (permalink)
Super Techie
 
Join Date: Jul 2004
Posts: 321
Default

isn't he talking about sound card issues?
__________________
|New|Gaming|System|2|Be|:

AMD 64 bit 3500+ Socket 939
MSI K8N Neo 2 Plat. Socket 939 mobo
Corsair TWINX1024-3200 RAM
Nvidia GeForce 6800 GT Graphic Card
Altec Lansing 5051 Speaker system
Creative Sound Blaster live 7.1
Maxtor SATA 200Gb HDD
Plextor PX-712A DVD±R/RW Drive
Wired Mouse/Keyboard by Logitech
Samsung 795MB Flat Screen CRT
Raidmax Scorpio 868W Casing
Antec Truepower 430 or 480
Thermaltake (Pipe101) Heatsink
Thermaltake Street Fighter Fan
derfist is offline  
Old 11-09-2004, 11:50 PM   #4 (permalink)
Banned
 
Join Date: Apr 2004
Posts: 559
Default

You don't understand. If the Video card hogs the PCI/AGP bus that will take away any available time for anything else. This has been known to cause major problems with sound cards. ATI's are set to override the systems BIOS programming for the PCI latency. That's why I asked him what kind of video card he has.
ChaosBlizzard is offline  
Old 11-10-2004, 01:48 AM   #5 (permalink)
Super Techie
 
Join Date: Jul 2004
Posts: 321
Default

ic,ic.
__________________
|New|Gaming|System|2|Be|:

AMD 64 bit 3500+ Socket 939
MSI K8N Neo 2 Plat. Socket 939 mobo
Corsair TWINX1024-3200 RAM
Nvidia GeForce 6800 GT Graphic Card
Altec Lansing 5051 Speaker system
Creative Sound Blaster live 7.1
Maxtor SATA 200Gb HDD
Plextor PX-712A DVD±R/RW Drive
Wired Mouse/Keyboard by Logitech
Samsung 795MB Flat Screen CRT
Raidmax Scorpio 868W Casing
Antec Truepower 430 or 480
Thermaltake (Pipe101) Heatsink
Thermaltake Street Fighter Fan
derfist is offline  
Old 11-10-2004, 06:58 AM   #6 (permalink)
Monster Techie
 
Join Date: Jan 2004
Posts: 1,124
Default

ive bought 2 - SB Audigy Platinum 2 cards for my home and work computers.Believe it or not i use the install CD to this day and i dont have any problems.I agree the Creative downloads "sense i last checked" are pathetic .But they do however offer a CD that you can buy.The onborad sound cards have gotten alot better over the years they produce good sound quality but are not as crisp in my opinion.But there still adequit
__________________
Thermaltake Armor A90
Corsair HX1000W PS
i7 2600k / Cooler Master Hyper N 520
Asus P8Z68-V Pro / Gen 3
8 GIG Corsair Vengeance
eVGA GTX 570
SB Audigy2 Platinum
Kingston Hyper X120 SSD
WIN 7 - 64b
LG Blue Ray Super Multi Burrner
Logitech THX Z560
3x120mm - 1x200 mm case fans
Cappy is offline  
Old 11-10-2004, 03:01 PM   #7 (permalink)
Junior Techie
 
Join Date: Jul 2004
Posts: 70
Default

I am aware of potential timing issues with graphics cards. That said I have an nvidia card geoforce 3 Ti 500. A little old but has been a real decent card throughout this systems lifecycle.
I am going to at least try out the onboard sound on my next system rather than exasperate myself. I find the creative cards fine as far as the audio goes and have used them for years. I just think the drivers suck.
I have already picked out the 9800 pro for my next system's graphics.....lol
__________________
nothing ventured.......nothing gained
Kaniver is offline  
Old 11-10-2004, 03:27 PM   #8 (permalink)
Banned
 
Join Date: Apr 2004
Posts: 559
Default

Don't know about that.. I have an Audigy 2 ZS PE and it works fine with the drivers right off their site..
ChaosBlizzard is offline  
Old 11-10-2004, 04:01 PM   #9 (permalink)
True Techie
 
Join Date: Oct 2004
Posts: 163
Send a message via Yahoo to xenosoul
Default

I've got an audigy one and every now and then it gives me problems.

Prob 1. Sometimes when playing RTCW or SW Galaxies the sound will cut off and I will have to reinstall the drivers off the disk.

Prob 2. I ran into a problem where the card uninstalled itself and it would not reinstall for like 20 minutes.. The PCI wouldnt see it. All is ok now exept for Prob 1.

PS. I dont know what i would do without my live drive
xenosoul is offline  
Old 11-10-2004, 04:53 PM   #10 (permalink)
Banned
 
Join Date: Apr 2004
Posts: 559
Default

What version of Windows are you running? Did you try using Creative's liveupdate from their site? That's what I did and I haven't had a problem. You might also want to check for updates on those games.. Many game vendor's release patches to help fix problems like that.

PS- What version of DirectX are you running?
__________________

ChaosBlizzard is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.