Computer won't turn on! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-25-2005, 11:41 AM   #1 (permalink)
Newb Techie
 
Join Date: Mar 2005
Posts: 13
Unhappy Computer won't turn on!

Hi everyone,

Just got some new components for my PC after a failure. I have got an ASUS P4V8X-X motherboard with a 2.4GHz Celeron D and 256MB RAM. I connected everything up (inc. BOTH ATX connectors) and plugged in the power. The little power LED on the board was lit showing power, but when i pressed the switch, nothing happens??? Connections are right, and i believe the switch works. The PSU is also brand new.
Can anyone help???

Thanks
__________________

XenonComputers is offline  
Old 03-25-2005, 11:56 AM   #2 (permalink)
Field Engineer
 
SHAWN's Avatar
 
Join Date: Nov 2004
Location: Long Island, NY
Posts: 4,697
Send a message via AIM to SHAWN
Default

Did you install the pegs that go under the mobo when you install it in the case?

Also, try using a screwdriver to touch the 2 pins that turn the computer on. If that works, then something is up with the connection or the button
__________________
A+, Network + , HP Certified Tech and MCP

Specs: AMD Phenom II X6 1095T, Asus M477TD, 8GB GSkill Ripjaws DDR3 1600 7-8-7-24 1T, 128GB Crucial M4 SSD, ATi HD4650, W7, 27" HL272 Monitor
SHAWN is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.